<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>How Google&#039;s Knowledge Graph Updates Itself by Answering Questions - SEO by the Sea &#9875;</title>

<meta property="og:site_name" content="SEO by the Sea &#9875;" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/" />
<meta property="og:title" content="How Google&#039;s Knowledge Graph Updates Itself by Answering Questions" />
<meta property="og:description" content="How A Knowledge Graph Updates Itself unsplash-logoElijah Hail To those of us who are used to doing Search Engine Optimization, we&#039;ve been looking at URLs filled with content, and links between that content, and how" />
<meta property="og:updated_time" content="2018-10-29T16:15:17+00:00" />
<meta property="article:published_time" content="2018-10-29T14:50:15+00:00" />
<meta property="article:modified_time" content="2018-10-29T16:15:17+00:00" />
<meta property="og:image" content="http://www.seobythesea.com/wp-content/knowledge-graph.jpg" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="750" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How Google&#039;s Knowledge Graph Updates Itself by Answering Questions" />
<meta name="twitter:description" content="How A Knowledge Graph Updates Itself unsplash-logoElijah Hail To those of us who are used to doing Search Engine Optimization, we&#039;ve been looking at URLs filled with content, and links between that content, and how" />
<meta name="twitter:image" content="http://www.seobythesea.com/wp-content/knowledge-graph.jpg" />


<meta name="description" content="Google explains how a knowledge Graph Updates itself by answering questions about its properties" />
<link rel="canonical" href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/" />
<link rel="publisher" href="https://plus.google.com/+Seobythesea/posts" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How Google&#039;s Knowledge Graph Updates Itself by Answering Questions - SEO by the Sea &#9875;" />
<meta property="og:description" content="Google explains how a knowledge Graph Updates itself by answering questions about its properties" />
<meta property="og:url" content="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/" />
<meta property="og:site_name" content="SEO by the Sea &#9875;" />
<meta property="article:publisher" content="https://www.facebook.com/bill.slawski" />
<meta property="article:author" content="https://www.facebook.com/bill.slawski" />
<meta property="article:section" content="Semantic Search" />
<meta property="article:published_time" content="2018-10-29T21:50:15+00:00" />
<meta property="article:modified_time" content="2018-10-29T23:15:17+00:00" />
<meta property="og:updated_time" content="2018-10-29T23:15:17+00:00" />
<meta property="og:image" content="http://www.seobythesea.com/wp-content/knowledge-graph.jpg" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="750" />
<meta property="og:image:alt" content="knowledge graph updates" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Google explains how a knowledge Graph Updates itself by answering questions about its properties" />
<meta name="twitter:title" content="How Google&#039;s Knowledge Graph Updates Itself by Answering Questions - SEO by the Sea &#9875;" />
<meta name="twitter:site" content="@bill_slawski" />
<meta name="twitter:image" content="http://www.seobythesea.com/wp-content/knowledge-graph.jpg" />
<meta name="twitter:creator" content="@bill_slawski" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"http:\/\/www.seobythesea.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"http:\/\/www.seobythesea.com\/category\/semantic-search\/","name":"Semantic Search"}},{"@type":"ListItem","position":3,"item":{"@id":"http:\/\/www.seobythesea.com\/2018\/10\/how-googles-knowledge-graph-updates-itself-by-answering-questions\/","name":"How Google&#8217;s Knowledge Graph Updates Itself by Answering Questions"}}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SEO by the Sea &#9875; &raquo; Feed" href="http://www.seobythesea.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SEO by the Sea &#9875; &raquo; Comments Feed" href="http://www.seobythesea.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="SEO by the Sea &#9875; &raquo; How Google&#8217;s Knowledge Graph Updates Itself by Answering Questions Comments Feed" href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/feed/" />

<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.3.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-6258590-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-6258590-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.seobythesea.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='cptch_stylesheet-css' href='http://www.seobythesea.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='http://www.seobythesea.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css' href='http://www.seobythesea.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='http://www.seobythesea.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='dpsp-frontend-style-css' href='http://www.seobythesea.com/wp-content/plugins/social-pug/assets/css/style-frontend.css?ver=2.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-fonts-css' href='https://fonts.googleapis.com/css?family=Merriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CMontserrat%3A400%2C700%7CInconsolata%3A400&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css' href='http://www.seobythesea.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-style-css' href='http://www.seobythesea.com/wp-content/themes/twentysixteen/style.css?ver=4.9.8' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='twentysixteen-ie-css'  href='http://www.seobythesea.com/wp-content/themes/twentysixteen/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentysixteen-ie8-css'  href='http://www.seobythesea.com/wp-content/themes/twentysixteen/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentysixteen-ie7-css'  href='http://www.seobythesea.com/wp-content/themes/twentysixteen/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css' href='http://www.seobythesea.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css?ver=6.2.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/www.seobythesea.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.3.0'></script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
			var dpsp_pin_button_data = {"button_position":"top_left","button_shape":"rectangular","minimum_image_width":"200","minimum_image_height":"200","show_button_text_label":"yes","button_text_label":"Save","pin_description_source":"image_alt_tag"}
		
</script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-content/plugins/social-pug/assets/js/front-end.js?ver=2.5.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.seobythesea.com/wp-content/themes/twentysixteen/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://www.seobythesea.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.seobythesea.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.seobythesea.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='http://www.seobythesea.com/?p=23034' />
<link rel="alternate" type="application/json+oembed" href="http://www.seobythesea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.seobythesea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F&#038;format=xml" />
<style type="text/css" data-source="Social Pug"></style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="http://www.seobythesea.com/wp-content/favicon.bmp" sizes="32x32" />
<link rel="icon" href="http://www.seobythesea.com/wp-content/favicon.bmp" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.seobythesea.com/wp-content/favicon.bmp" />
<meta name="msapplication-TileImage" content="http://www.seobythesea.com/wp-content/favicon.bmp" />
</head>
<body class="post-template-default single single-post postid-23034 single-format-standard group-blog">
<div id="page" class="site">
<div class="site-inner">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner">
<div class="site-header-main">
<div class="site-branding">
<p class="site-title"><a href="http://www.seobythesea.com/" rel="home">SEO by the Sea &#9875;</a></p>
<p class="site-description">Learn SEO Directly from the Search Engines</p>
</div>
<button id="menu-toggle" class="menu-toggle">Menu</button>
<div id="site-header-menu" class="site-header-menu">
<nav id="site-navigation" class="main-navigation" role="navigation" aria-label="Primary Menu">
<div class="menu-sitepages-container"><ul id="menu-sitepages" class="primary-menu"><li id="menu-item-12176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12176"><a href="http://www.seobythesea.com">Blog</a></li>
<li id="menu-item-11759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11759"><a href="http://www.seobythesea.com/faq/">FAQ</a></li>
<li id="menu-item-4296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4296"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/">Services</a>
<ul class="sub-menu">
<li id="menu-item-14179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14179"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/local-search-seo/">Local SEO Services</a></li>
<li id="menu-item-14181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14181"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/seo-site-audit-and-recommendations/">SEO Audit</a></li>
<li id="menu-item-14180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14180"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/seo-training-and-coaching/">SEO Training and Coaching</a></li>
<li id="menu-item-14193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14193"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/link-building-strategies/">Link Building Strategies</a></li>
<li id="menu-item-14182" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14182"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/keyword-research/">Keyword Research</a></li>
</ul>
</li>
<li id="menu-item-4298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4298"><a href="http://www.seobythesea.com/about-seo-by-the-sea/">About</a>
<ul class="sub-menu">
<li id="menu-item-17899" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17899"><a href="http://www.seobythesea.com/seo-testimonials/">SEO Testimonials</a></li>
</ul>
</li>
<li id="menu-item-4299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4299"><a href="http://www.seobythesea.com/recommended-seo-and-usability-reading/">Resources</a>
<ul class="sub-menu">
<li id="menu-item-13402" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13402"><a href="http://www.seobythesea.com/recommended-seo-and-usability-reading/semantic-web-resources/">Semantic Web Resources</a></li>
</ul>
</li>
<li id="menu-item-4297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4297"><a href="http://www.seobythesea.com/contact-us/">Contact</a></li>
<li id="menu-item-4294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4294"><a href="http://www.seobythesea.com/subscribe/">Subscribe</a></li>
<li id="menu-item-11622" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11622"><a href="http://www.seobythesea.com/privacy-policy/">Privacy</a></li>
</ul></div> </nav>
</div>
</div>
<div class="header-image">
<a href="http://www.seobythesea.com/" rel="home">
<img src="http://www.seobythesea.com/wp-content/cropped-ponto-beach-2.jpg" srcset="http://www.seobythesea.com/wp-content/cropped-ponto-beach-2-300x70.jpg 300w, http://www.seobythesea.com/wp-content/cropped-ponto-beach-2-768x179.jpg 768w, http://www.seobythesea.com/wp-content/cropped-ponto-beach-2-1024x239.jpg 1024w, http://www.seobythesea.com/wp-content/cropped-ponto-beach-2.jpg 1200w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 81vw, (max-width: 1362px) 88vw, 1200px" width="1200" height="280" alt="SEO by the Sea &#9875;">
</a>
</div>
</header>
<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<article id="post-23034" class="post-23034 post type-post status-publish format-standard has-post-thumbnail hentry category-semantic-search">
<header class="entry-header">
<h1 class="entry-title">How Google&#8217;s Knowledge Graph Updates Itself by Answering Questions</h1> </header>
<div class="post-thumbnail">
<img width="500" height="750" src="http://www.seobythesea.com/wp-content/knowledge-graph.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="knowledge graph updates" srcset="http://www.seobythesea.com/wp-content/knowledge-graph.jpg 500w, http://www.seobythesea.com/wp-content/knowledge-graph-200x300.jpg 200w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 60vw, (max-width: 1362px) 62vw, 840px" /> </div>
<div class="entry-content">
<p class="dpsp-share-text">Sharing is caring!</p><div id="dpsp-content-top" class="dpsp-content-wrapper dpsp-shape-rounded dpsp-size-small dpsp-has-spacing dpsp-has-buttons-count dpsp-show-on-mobile dpsp-show-total-share-count dpsp-show-total-share-count-after dpsp-button-style-2"><div class="dpsp-total-share-wrapper"><span class="dpsp-icon-total-share"></span><span class="dpsp-total-share-count">167</span><span>shares</span></div><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content dpsp-networks-btns-share dpsp-column-auto dpsp-has-button-icon-animation"><li><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F&t=How+Google%27s+Knowledge+Graph+Updates+Itself+by+Answering+Questions" class="dpsp-network-btn dpsp-facebook dpsp-has-count dpsp-first"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Facebook</span><span class="dpsp-network-count">26</span></span></a></li><li><a rel="nofollow" href="https://twitter.com/intent/tweet?text=How+Google%27s+Knowledge+Graph+Updates+Itself+by+Answering+Questions&url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F" class="dpsp-network-btn dpsp-twitter dpsp-has-count"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Twitter</span><span class="dpsp-network-count">139</span></span></a></li><li><a rel="nofollow" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F" class="dpsp-network-btn dpsp-google-plus"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Google+</span></span></a></li><li><a rel="nofollow" href="https://www.linkedin.com/shareArticle?url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F&title=How+Google%27s+Knowledge+Graph+Updates+Itself+by+Answering+Questions&summary=How+A+Knowledge+Graph+Updates+Itself+unsplash-logoElijah+Hail+To+those+of+us+who+are+used+to+doing+Search+Engine+Optimization%2C+we%27ve+been+looking+at+URLs+filled+with+content%2C+and+links+between+that+content%2C+and+how&mini=true" class="dpsp-network-btn dpsp-linkedin"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">LinkedIn</span></span></a></li><li><a rel="nofollow" data-href="#" class="dpsp-network-btn dpsp-pinterest dpsp-has-count dpsp-last"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Pinterest</span><span class="dpsp-network-count">2</span></span></a></li></ul></div><h2>How A Knowledge Graph Updates Itself</h2>
<p><a style="background-color:black;color:white;text-decoration:none;padding:4px 6px;font-family:-apple-system, BlinkMacSystemFont, &quot;San Francisco&quot;, &quot;Helvetica Neue&quot;, Helvetica, Ubuntu, Roboto, Noto, &quot;Segoe UI&quot;, Arial, sans-serif;font-size:12px;font-weight:bold;line-height:1.2;display:inline-block;border-radius:3px" href="https://unsplash.com/@elijahhail?utm_medium=referral&amp;utm_campaign=photographer-credit&amp;utm_content=creditBadge" target="_blank" rel="noopener noreferrer" title="Download free do whatever you want high-resolution photos from Elijah Hail"><span style="display:inline-block;padding:2px 3px"><svg xmlns="http://www.w3.org/2000/svg" style="height:12px;width:auto;position:relative;vertical-align:middle;top:-1px;fill:white" viewBox="0 0 32 32"><title>unsplash-logo</title><path d="M20.8 18.1c0 2.7-2.2 4.8-4.8 4.8s-4.8-2.1-4.8-4.8c0-2.7 2.2-4.8 4.8-4.8 2.7.1 4.8 2.2 4.8 4.8zm11.2-7.4v14.9c0 2.3-1.9 4.3-4.3 4.3h-23.4c-2.4 0-4.3-1.9-4.3-4.3v-15c0-2.3 1.9-4.3 4.3-4.3h3.7l.8-2.3c.4-1.1 1.7-2 2.9-2h8.6c1.2 0 2.5.9 2.9 2l.8 2.4h3.7c2.4 0 4.3 1.9 4.3 4.3zm-8.6 7.5c0-4.1-3.3-7.5-7.5-7.5-4.1 0-7.5 3.4-7.5 7.5s3.3 7.5 7.5 7.5c4.2-.1 7.5-3.4 7.5-7.5z"></path></svg></span><span style="display:inline-block;padding:2px 3px">Elijah Hail</span></a></p>
<p>To those of us who are used to doing Search Engine Optimization, we&#8217;ve been looking at URLs filled with content, and links between that content, and how algorithms such as <a href="https://en.wikipedia.org/wiki/PageRank">PageRank</a> (based upon links pointed between pages) and <a href="https://en.wikipedia.org/wiki/Ranking_(information_retrieval)">information retrieval scores</a> based upon the relevance of that content have been determining how well pages rank in search results in response to queries entered into search boxes by searchers. Web pages connected by links have been seen as information points connected by nodes. This was the first generation of SEO. </p>
<p>Search has been going through a transformation. Back in 2012, Google introduced something it refers to as the <a href+"https: en.wikipedia.org wiki Knowledge_Graph">knowledge graph</a>, in which they told us that they would begin focusing upon indexing things instead of strings. By &#8220;strings,&#8221; they were referring to words that appear in queries, and in documents on the Web. By &#8220;things,&#8221; they were referring to named entities, or real and specific people, places, and things. When people searched at Google, the search engines would show Search Engine Results Pages (SERPs) filled with URLs to pages that contained the strings of letters that we were searching for. Google still does that, and is slowly changing to showing search results that are about people, places, and things. </p>
<p><span id="more-23034"></span></p>
<p>Google started showing us in patents how they were introducing entity recognition to search, as I described in this post:<br />
<a href="https://gofishdigital.com/google-entity-recognition/">How Google May Perform Entity Recognition</a></p>
<p>They now show us <a href="http://www.seobythesea.com/2015/03/googles-knowledge-cards/">knowledge panels in search results</a> that tell us about the people, places, and things they recognize in the queries we perform. In addition to crawling webpages and indexing the words on those pages, Google is collecting facts about the people, places, and things it finds on those pages.</p>
<p>A Google Patent that was just granted in the past week tells us about how Google&#8217;s knowledge graph updates itself when it collects information about entities, their properties and attributes and relationships involving them. This is part of the evolution of SEO that is taking place today &#8211; learning how Search is changing from being based upon search to being based upon knowledge. </p>
<p>What does the patent tell us about knowledge? This is one of the sections that details what a knowledge graph is like that Google might collect information about when it indexes pages these days:</p>
<blockquote><p>Knowledge graph portion includes information related to the entity [George Washington], represented by [George Washington] node. [George Washington] node is connected to [U.S. President] entity type node by [Is A] edge with the semantic content [Is A], such that the 3-tuple defined by nodes and the edge contains the information &#8220;George Washington is a U.S. President.&#8221; Similarly, &#8220;Thomas Jefferson Is A U.S. President&#8221; is represented by the tuple of [Thomas Jefferson] node 310, [Is A] edge, and [U.S. President] node. Knowledge graph portion includes entity type nodes [Person], and [U.S. President] node. The person type is defined in part by the connections from [Person] node. For example, the type [Person] is defined as having the property [Date Of Birth] by node and edge, and is defined as having the property [Gender] by node 334 and edge 336. These relationships define in part a schema associated with the entity type [Person].</p></blockquote>
<p>Note that SEO is no longer just about how often certain words appear on pages of the Web, what words appear in links to those pages, in page titles, and headings, alt text for images, and how often certain words may be repeated or related words may be used. Google is looking at the facts that are mentioned about entities, such as entity types like a &#8220;person,&#8221; and properties, such as &#8220;Date of Birth,&#8221; or &#8220;Gender.&#8221;</p>
<p>Note that quote also mentions the word &#8220;Schema&#8221; as in &#8220;These relationships define in part a schema associated with the entity type [Person].&#8221; As part of the transformation of SEO from Strings to Things, The major Search Engines joined forces to offer us information on how to use <a href="https://schema.org/">Schema</a> for structured data on the Web to provide a machine readable way of sharing information with search engines about the entities that we write about, their properties, and relationships.</p>
<p>I&#8217;m writing about this patent because I am participating in a Webinar online about Knowledge Graphs and how those are being used, and updated. The Webinar is tomorrow at:<br />
<a href="https://www.semrush.com/webinars/seoisaeo-how-google-uses-the-knowledge-graph-in-its-ae-algorithm/">#SEOisAEO: How Google Uses The Knowledge Graph in its AE algorithm</a>. I haven&#8217;t been referring to SEO as Answer Engine Optimization, or AEO and it&#8217;s unlikely that I will start, but see it as an evolution of SEO</p>
<p>I&#8217;m writing about this Google Patent, because it starts out with the following line which it titles &#8220;Background:&#8221;</p>
<p><em>This disclosure generally relates to updating information in a database. Data has previously been updated by, for example, user input.</em></p>
<p>This line points to the fact that this approach no longer needs to be updated by users, but instead involves how Google knowledge graphs update themselves.</p>
<h2>Updating Knowledge Graphs</h2>
<p> I attended a Semantic Technology and Business conference a couple of year ago, where the head of Yahoo&#8217;s knowledge base presented, and he was asked a number of questions in a question and answer session after he spoke. Someone asked him what happens when information from a knowledge graph changes and it needs to be updated?</p>
<p>His Answer was that a knowledge graph would have to be updated manually to have new information place within it.</p>
<p>That wasn&#8217;t a satisfactory answer because it would have been good to hear that the information from such a source could be easily updated. I&#8217;ve been waiting for Google to answer a question like this, which made seeing a line like this one from this patent a good experience:</p>
<blockquote><p>In some implementations, a system identifies information that is missing from a collection of data. The system generates a question to provide to a question answering service based on the missing information, and uses the response from the question answering service to update the collection of data.</p></blockquote>
<p>This would be a knowledge graph update, so that patent provides details using language that reflects that exacly:</p>
<blockquote><p>In some implementations, a computer-implemented method is provided. The method includes identifying an entity reference in a knowledge graph, wherein the entity reference corresponds to an entity type. The method further includes identifying a missing data element associated with the entity reference. The method further includes generating a query based at least in part on the missing data element and the type of the entity reference. The method further includes providing the query to a query processing engine. The method further includes receiving information from the query processing engine in response to the query. The method further includes updating the knowledge graph based at least in part on the received information.</p></blockquote>
<p>How does the search engine do this? The patent provides more information that fills in such details.</p>
<p>The approaches to achieve this would be to:</p>
<blockquote><p>&#8230;Identifying a missing data element comprises comparing properties associated with the entity reference to a schema table associated with the entity type.</p></blockquote>
<blockquote><p>&#8230;Generating the query comprises generating a natural language query. This can involve selecting, from the knowledge graph, disambiguation query terms associated with the entity reference, wherein the terms comprise property values associated with the entity reference, or updating the knowledge graph by updating the data graph to include information in place of the missing data element.</p></blockquote>
<blockquote><p>&#8230;Identifying an element in a knowledge graph to be updated based at least in part on a query record. Operations further include generating a query based at least in part on the identified element. Operations further include providing the query to a query processing engine. Operations further include receiving information from the query processing engine in response to the query. Operations further include updating the knowledge graph based at least in part on the received information.</p>
<p>A knowledge graph updates itself in these ways: </p>
<p>(1) The knowledge Graph may be updated with one or more previously performed searches.<br />
(2) The knowledge Graph may be updated with a natural language query, using disambiguation query terms associated with the entity reference, wherein the terms comprise property values associated with the entity reference.<br />
(3) The knowledge Graph may use properties associated with the entity reference to include information updating missing data elements.</p>
<p>The patent that describes how Google&#8217;s knowledge graph updates themselves is:</p>
<p><a href="http://patft.uspto.gov/netacgi/nph-Parser?Sect1=PTO1&#038;Sect2=HITOFF&#038;d=PALL&#038;p=1&#038;u=%2Fnetahtml%2FPTO%2Fsrchnum.htm&#038;r=1&#038;f=G&#038;l=50&#038;s1=10,108,700.PN.&#038;OS=PN/10,108,700&#038;RS=PN/10,108,700">Question answering to populate knowledge base</a><br />
Inventors: Rahul Gupta, Shaohua Sun, John Blitzer, Dekang Lin, Evgeniy Gabrilovich<br />
Assignee: Google<br />
US Patent: 10,108,700<br />
Granted: October 23, 2018<br />
Filed: March 15, 2013</p>
<p>Abstract</p>
<blockquote><p>Methods and systems are provided for a question answering. In some implementations, a data element to be updated is identified in a knowledge graph and a query is generated based at least in part on the data element. The query is provided to a query processing engine. Information is received from the query processing engine in response to the query. The knowledge graph is updated based at least in part on the received information.</p></blockquote>
</blockquote>
<p class="dpsp-share-text">Sharing is caring!</p><div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-rounded dpsp-size-small dpsp-has-spacing dpsp-has-buttons-count dpsp-show-on-mobile dpsp-show-total-share-count dpsp-show-total-share-count-after dpsp-button-style-2"><div class="dpsp-total-share-wrapper"><span class="dpsp-icon-total-share"></span><span class="dpsp-total-share-count">167</span><span>shares</span></div><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content dpsp-networks-btns-share dpsp-column-auto dpsp-has-button-icon-animation"><li><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F&t=How+Google%27s+Knowledge+Graph+Updates+Itself+by+Answering+Questions" class="dpsp-network-btn dpsp-facebook dpsp-has-count dpsp-first"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Facebook</span><span class="dpsp-network-count">26</span></span></a></li><li><a rel="nofollow" href="https://twitter.com/intent/tweet?text=How+Google%27s+Knowledge+Graph+Updates+Itself+by+Answering+Questions&url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F" class="dpsp-network-btn dpsp-twitter dpsp-has-count"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Twitter</span><span class="dpsp-network-count">139</span></span></a></li><li><a rel="nofollow" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F" class="dpsp-network-btn dpsp-google-plus"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Google+</span></span></a></li><li><a rel="nofollow" href="https://www.linkedin.com/shareArticle?url=http%3A%2F%2Fwww.seobythesea.com%2F2018%2F10%2Fhow-googles-knowledge-graph-updates-itself-by-answering-questions%2F&title=How+Google%27s+Knowledge+Graph+Updates+Itself+by+Answering+Questions&summary=How+A+Knowledge+Graph+Updates+Itself+unsplash-logoElijah+Hail+To+those+of+us+who+are+used+to+doing+Search+Engine+Optimization%2C+we%27ve+been+looking+at+URLs+filled+with+content%2C+and+links+between+that+content%2C+and+how&mini=true" class="dpsp-network-btn dpsp-linkedin"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">LinkedIn</span></span></a></li><li><a rel="nofollow" data-href="#" class="dpsp-network-btn dpsp-pinterest dpsp-has-count dpsp-last"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Pinterest</span><span class="dpsp-network-count">2</span></span></a></li></ul></div> </div>
<footer class="entry-footer">
<span class="byline"><span class="author vcard"><img alt='' src='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=49&#038;r=g' srcset='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=98&#038;r=g 2x' class='avatar avatar-49 photo' height='49' width='49' /><span class="screen-reader-text">Author </span> <a class="url fn n" href="http://www.seobythesea.com/author/billbill/">Bill Slawski</a></span></span><span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/" rel="bookmark"><time class="entry-date published" datetime="2018-10-29T14:50:15+00:00">10/29/2018</time><time class="updated" datetime="2018-10-29T16:15:17+00:00">10/29/2018</time></a></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://www.seobythesea.com/category/semantic-search/" rel="category tag">Semantic Search</a></span> </footer>
</article>
<div id="comments" class="comments-area">
<h2 class="comments-title">
11 thoughts on &ldquo;How Google&#8217;s Knowledge Graph Updates Itself by Answering Questions&rdquo; </h2>
<ol class="comment-list">
<li id="comment-559375" class="comment even thread-even depth-1">
<article id="div-comment-559375" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://2.gravatar.com/avatar/ee83c9324c56253aa75e87802739203c?s=42&#038;r=g' srcset='http://2.gravatar.com/avatar/ee83c9324c56253aa75e87802739203c?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn">Dan Astriden</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559375">
<time datetime="2018-10-29T15:21:50+00:00">
10/29/2018 at 3:21 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>This is a great post about the fundamental shift in SEO and how search engines are getting smarter as they strive towards complete natural language processing. It&#8217;s imperative to manage business data and ensure clarity about your brand around the web.</p>
</div>
</article>
</li>
<li id="comment-559376" class="comment byuser comment-author-billbill bypostauthor odd alt thread-odd thread-alt depth-1">
<article id="div-comment-559376" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=42&#038;r=g' srcset='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='http://www.seobythesea.com' rel='external nofollow' class='url'>Bill Slawski</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559376">
<time datetime="2018-10-29T17:27:58+00:00">
10/29/2018 at 5:27 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Hi Dan,</p>
<p>That shift from strings to things, where it is not so much about matching keywords, but instead, about answering questions involving things. A search engine should be capable of filling in knowledge gaps in a knowledge graph about properties of an entity included in that knowledge graph, and by updating that graph, it becomes capable of answering questions about things that weren&#8217;t originally included in that knowledge graph. It is going to be interesting seeing how Google evolves beyond where it is at now.</p>
</div>
</article>
</li>
<li id="comment-559379" class="comment even thread-even depth-1">
<article id="div-comment-559379" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://1.gravatar.com/avatar/44346d960675b61703fd5fa8e8cf2d79?s=42&#038;r=g' srcset='http://1.gravatar.com/avatar/44346d960675b61703fd5fa8e8cf2d79?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='https://trekkingteamgroup.com/nepal-trips/trekking-hiking-holidays/annapurna-base-camp-trek' rel='external nofollow' class='url'>Annapurna Base Camp Trek</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559379">
<time datetime="2018-10-29T23:05:55+00:00">
10/29/2018 at 11:05 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>This is great information about google and its knowledge graph.Keep updating ..</p>
</div>
</article>
</li>
<li id="comment-559405" class="comment odd alt thread-odd thread-alt depth-1">
<article id="div-comment-559405" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://2.gravatar.com/avatar/51994dbb3649ee8a61a972fb1e8caefd?s=42&#038;r=g' srcset='http://2.gravatar.com/avatar/51994dbb3649ee8a61a972fb1e8caefd?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='http://www.rokucom.org/link/' rel='external nofollow' class='url'>Anup upadhyay</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559405">
<time datetime="2018-10-30T03:23:29+00:00">
10/30/2018 at 3:23 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Very nice blog thanks for sharing keep it up we supported you.</p>
</div>
</article>
</li>
<li id="comment-559412" class="comment even thread-even depth-1">
<article id="div-comment-559412" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://0.gravatar.com/avatar/9555d199284502776ee160a9143302e6?s=42&#038;r=g' srcset='http://0.gravatar.com/avatar/9555d199284502776ee160a9143302e6?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='http://dixonjones.com' rel='external nofollow' class='url'>Dixon</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559412">
<time datetime="2018-10-30T05:21:30+00:00">
10/30/2018 at 5:21 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>The connectedness of all things! 🙂</p>
<p>I love that Google’s AI maybe asking questions on Q&amp;A forums to fill in gaps! It does pose the new ethical question &#8211; are we the bots now?</p>
</div>
</article>
</li>
<li id="comment-559415" class="comment byuser comment-author-billbill bypostauthor odd alt thread-odd thread-alt depth-1">
<article id="div-comment-559415" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=42&#038;r=g' srcset='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='http://www.seobythesea.com' rel='external nofollow' class='url'>Bill Slawski</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559415">
<time datetime="2018-10-30T06:26:14+00:00">
10/30/2018 at 6:26 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Hi Dixon,</p>
<p>Maybe not a Q&#038;A forum or an Ask Yahoo!, but lots of people ask Google questions daily. If Queries can be rewritten, and disambiguated, and new trending answers can be discovered, The knowledge Graph can be updated quickly when there are gaps in knowledge. We will see how that works. 🙂</p>
</div>
</article>
</li>
<li id="comment-559419" class="comment even thread-even depth-1">
<article id="div-comment-559419" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://1.gravatar.com/avatar/13cae9d4c6ce262ace9c38233558e339?s=42&#038;r=g' srcset='http://1.gravatar.com/avatar/13cae9d4c6ce262ace9c38233558e339?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn">LOREN MCKECHNIE</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559419">
<time datetime="2018-10-30T11:36:16+00:00">
10/30/2018 at 11:36 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Just wait until Google Duplex (the 2 way conversation phone calling bot)is calling professors with data from Google + to get the answers to those tough questions. Maybe suggesting they write a blog post about the topic.</p>
</div>
</article>
</li>
<li id="comment-559420" class="comment byuser comment-author-billbill bypostauthor odd alt thread-odd thread-alt depth-1">
<article id="div-comment-559420" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=42&#038;r=g' srcset='http://2.gravatar.com/avatar/83051606d16792aaa2e9fee631696efe?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='http://www.seobythesea.com' rel='external nofollow' class='url'>Bill Slawski</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559420">
<time datetime="2018-10-30T14:16:49+00:00">
10/30/2018 at 2:16 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Hi Loren,</p>
<p>That would be the phone-a-friend option? That sounds similar to what Google did around 2 years ago to start providing better health-related featured snippets. They hired a number of doctors to write out answers. We shall see what Google does.</p>
</div>
</article>
</li>
<li id="comment-559438" class="comment even thread-even depth-1">
<article id="div-comment-559438" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://2.gravatar.com/avatar/ed73711d0cfcf46994cc2bac12ada220?s=42&#038;r=g' srcset='http://2.gravatar.com/avatar/ed73711d0cfcf46994cc2bac12ada220?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='https://albadesign.ro' rel='external nofollow' class='url'>Dorin</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559438">
<time datetime="2018-10-31T01:33:23+00:00">
10/31/2018 at 1:33 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Amazing article, thanks for sharing!</p>
</div>
</article>
</li>
<li id="comment-559441" class="comment odd alt thread-odd thread-alt depth-1">
<article id="div-comment-559441" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://2.gravatar.com/avatar/e0530b92e9a680d62aeca5694d7e3660?s=42&#038;r=g' srcset='http://2.gravatar.com/avatar/e0530b92e9a680d62aeca5694d7e3660?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='https://www.weareinfront.com/' rel='external nofollow' class='url'>Lauren Squire</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559441">
<time datetime="2018-10-31T02:10:06+00:00">
10/31/2018 at 2:10 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Great post on the intricate workings of the Knowledge Graph!</p>
</div>
</article>
</li>
<li id="comment-559449" class="comment even thread-even depth-1">
<article id="div-comment-559449" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='http://0.gravatar.com/avatar/6660ca85a721d8212b1a48d47c66d63c?s=42&#038;r=g' srcset='http://0.gravatar.com/avatar/6660ca85a721d8212b1a48d47c66d63c?s=84&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' /> <b class="fn"><a href='http://israel-tour-guide.com/' rel='external nofollow' class='url'>Gilad Suffrin</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="http://www.seobythesea.com/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/#comment-559449">
<time datetime="2018-10-31T04:38:22+00:00">
10/31/2018 at 4:38 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>very informative post. It’s a new thing to my knowledge. Thanks for sharing..</p>
<p>Wikipedia is the most common warehouse of knowledge. I like to grab a sentence from your post.</p>
</div>
</article>
</li>
</ol>
<div id="respond" class="comment-respond">
<h2 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/10/how-googles-knowledge-graph-updates-itself-by-answering-questions/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+seobythesea%2FTesr+%28SEO+by+the+Sea%29#respond" style="display:none;">Cancel reply</a></small></h2> <form action="http://www.seobythesea.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment-d80e50c2bb734c768b8cfef7" cols="45" rows="8" maxlength="65525" required="required"></textarea><textarea name="comment" rows="1" cols="1" style="display:none"></textarea></p><input type="hidden" name="comment-replaced" value="true" /><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='23034' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7107cc6fe5" /></p>

<p class="antispam-group antispam-group-q" style="clear: both;">
<label>Current <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e09985a092">[email&#160;protected]</a> <span class="required">*</span></label>
<input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2018" />
<input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="5.2" autocomplete="off" />
</p>
<p class="antispam-group antispam-group-e" style="display: none;">
<label>Leave this field empty</label>
<input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off" />
</p>
<p style="display:none;"><input type="text" name="nxts" value="1541073401" /><input type="text" name="nxts_signed" value="06b4f8846e8733edebb83f71a225d86f777ca663" /><input type="text" name="be55101a63541f853ef12abdaa744" value="305205741b40fc9b2df806d1c97c7296" /><input type="text" name="5e79e9743ae50f" value="" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="168" /></p> </form>
</div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div>
<nav class="navigation post-navigation" role="navigation">
<h2 class="screen-reader-text">Post navigation</h2>
<div class="nav-links"><div class="nav-previous"><a href="http://www.seobythesea.com/2018/10/how-google-might-identify-primary-versions-of-duplicate-pages/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">How Google might Identify Primary Versions of Duplicate Pages</span></a></div></div>
</nav>
</main>
<aside id="content-bottom-widgets" class="content-bottom-widgets" role="complementary">
<div class="widget-area">
<section id="categories-371234603" class="widget widget_categories"><h2 class="widget-title">Categories</h2> <ul>
<li class="cat-item cat-item-18"><a href="http://www.seobythesea.com/category/acquisitions/" title="Acquisitions, mergers, and strategic investments have the potential to transform the technologies that power the Web.  Companies like Google or Yahoo have made acquisitions of other companies for their technology, or to hire their employees because they have experience that might otherwise be difficult to acquire.

When writing about acquisitions, I have tried to include links to granted patents and patent applications that may have come with the acquisition as well.

Most news about acquisitions made on the web for technology companies doesn&#039;t include information about the finances involved in those acquisitions.">Acquisitions</a>
</li>
<li class="cat-item cat-item-343"><a href="http://www.seobythesea.com/category/analytics/" title="Analytics involves measuring activity on your site, which can help you understand what people do when they visit your pages.
The search engines have developed tools that site owners can use to learn about visitor activity on their sites.
Making sure analytics is set up correctly on your pages can be helpful, and knowing what the search engines make available is wise.">Analytics</a>
</li>
<li class="cat-item cat-item-179"><a href="http://www.seobythesea.com/category/blogging/" title="Posts, ideas, suggestions and questions on blogging, and using a blog. A Blog is short for Web log, which is a log of posts from a person, using focusing on a specific topic. 

Many commercial sites have blogs, which they can use to provide news and information to potential customers and provide information that might be found on a search by a search engine.

Many blogs are hobby sites for people who are interested in a specific topic and may be an outlet for their owners to use to share information about the subject of their blog.">Blogging</a>
</li>
<li class="cat-item cat-item-29"><a href="http://www.seobythesea.com/category/change/">Change</a>
</li>
<li class="cat-item cat-item-6"><a href="http://www.seobythesea.com/category/culture/" title="This is my place to write about culture in the SEO or Search Industries or in life.
It&#039;s not a Topic I add to very often but is one that I will occasionally write to.">Culture</a>
</li>
<li class="cat-item cat-item-11"><a href="http://www.seobythesea.com/category/design/" title="Posts on Web design and development covered at SEO by the Sea">Design and Development</a>
</li>
<li class="cat-item cat-item-27"><a href="http://www.seobythesea.com/category/environmental/" title="I sometimes write about the environmental influences in the world around me.  It&#039;s one of those things that call to me, and makes me pay attention to the world.">Environmental</a>
</li>
<li class="cat-item cat-item-4"><a href="http://www.seobythesea.com/category/events/" title="Information about events, conferences, and gatherings involving search, seo. technology and the Web.
This is where I will write about conferences and events that I attend, and include photos to show what takes place at such events, and where they take place.">Events</a>
</li>
<li class="cat-item cat-item-24"><a href="http://www.seobythesea.com/category/fact-extraction/" title="Techniques and approaches that search engines might use to do fact extraction and information from the Web, as uncovered in search-related patents and whitepapers.

These approaches may include natural language processing and knowledge bases, as well as how a search engine may do things such as question-answering.

Patents and papers involving concepts, entities, and knowledge Graphs will be covered by posts in this category.">Fact Extraction and Knowledge Graphs</a>
</li>
<li class="cat-item cat-item-12"><a href="http://www.seobythesea.com/category/gadgets/">Gadgets</a>
</li>
<li class="cat-item cat-item-392"><a href="http://www.seobythesea.com/category/google-glass/">Google Glass</a>
</li>
<li class="cat-item cat-item-266"><a href="http://www.seobythesea.com/category/seo-for-government/" title="Research, thoughts, and observations on search engine optimization and content development for government web sites">Government SEO</a>
</li>
<li class="cat-item cat-item-14"><a href="http://www.seobythesea.com/category/internet-law/" title="Local, regional, national, and international laws and regulations can impact the way that the Web works, and how businesses and organizations and individuals can use the Web.  Posts under this category explore Internet law and changes to laws involving the internet.">Internet Law</a>
</li>
<li class="cat-item cat-item-25"><a href="http://www.seobythesea.com/category/interviews/">Interviews</a>
</li>
<li class="cat-item cat-item-391"><a href="http://www.seobythesea.com/category/keyword-research/" title="This section is about keyword research and choosing specific words to optimize a page for, based upon the words that members of the targeted audience of a page might choose to use to search with, and expect to see on the pages of a site they find in search results.">Keyword Research</a>
</li>
<li class="cat-item cat-item-447"><a href="http://www.seobythesea.com/category/learning-seo/" title="There aren&#039;t many classes to attend to learn about SEO with.  So, this category focuses upon how someone can find Information and resources to learn SEO with.">Learning SEO</a>
</li>
<li class="cat-item cat-item-17"><a href="http://www.seobythesea.com/category/local-search/" title="Like organic search, one of the areas of search that brings a lot of traffic to businesses is Local SEO and Maps.

There have been a number of patents that focus upon local search, and show that it is often about structured data and Semantic marketing.
This is an area where citations have as much value as links, and businesses are considered local entities.

When you optimize a site for a business, often optimizing it for organic search and for local seo providing two separate sets of signals that business can be found through.

One of the earliest patents involving local search at Google was about collecting structured data about local business entities from sources such as data aggregators, enterprise business sites, and local business directories, which has them focusing upon consistency between those data sources, which is a major concern for local SEO.">Local SEO and Maps</a>
</li>
<li class="cat-item cat-item-23"><a href="http://www.seobythesea.com/category/media-search/">Media SEO</a>
</li>
<li class="cat-item cat-item-9"><a href="http://www.seobythesea.com/category/metablogging/" title="Information about the SEO by the Sea Blog, blogging, and so on.">Metablogging</a>
</li>
<li class="cat-item cat-item-15"><a href="http://www.seobythesea.com/category/mobile-search/" title="The amount of people accessing the Web on mobile phones and devices has been outpacing desktop computer users.
Google has been trying to convince site owners to make their sites mobile-friendly, and there have been some patents and papers focusing upon mobile devices accessing the Web.">Mobile and Mobile Search Marketing</a>
</li>
<li class="cat-item cat-item-393"><a href="http://www.seobythesea.com/category/mythbusting-seo/" title="There&#039;s a lot of misinformation on the Web about SEO, and this section of my blog is a place to discuss and unravel it.">Mythbusting SEO</a>
</li>
<li class="cat-item cat-item-413"><a href="http://www.seobythesea.com/category/open-data/">Open Data</a>
</li>
<li class="cat-item cat-item-408"><a href="http://www.seobythesea.com/category/paid-search/">Paid Search</a>
</li>
<li class="cat-item cat-item-394"><a href="http://www.seobythesea.com/category/patent-free-friday/">Patent Free Friday</a>
</li>
<li class="cat-item cat-item-448"><a href="http://www.seobythesea.com/category/relevance/">Relevance</a>
</li>
<li class="cat-item cat-item-13"><a href="http://www.seobythesea.com/category/sea/" title="Posts about white papers, patent filings, information, and strategies and tactics involving Search Engine Advertising">Search Engine Marketing (SEM)</a>
</li>
<li class="cat-item cat-item-5"><a href="http://www.seobythesea.com/category/seo/" title="Search Engine Optimization tips and strategies and information, from SEO by the Sea, to help make websites easier to find.
Search Engine Optimization is marketing within the framework of the Web.  Having an understanding of how Search Engines might crawl and index pages on the web, and rank content from those pages can help a site rank better in Search Results.">Search Engine Optimization (SEO)</a>
</li>
<li class="cat-item cat-item-10"><a href="http://www.seobythesea.com/category/search-engines-and-directories/" title="News and information about search engines and directories on the Web, including patent filings and white papers">Search Engines and Directories</a>
</li>
<li class="cat-item cat-item-19"><a href="http://www.seobythesea.com/category/search-people-moving/">Search People Moving</a>
</li>
<li class="cat-item cat-item-22"><a href="http://www.seobythesea.com/category/personalization/" title="Will search personalization transform search engines from keyword-driven finders of information to sources of recommendations that attempt to understand and match the intent behind searches?">Search Personalization</a>
</li>
<li class="cat-item cat-item-21"><a href="http://www.seobythesea.com/category/searchers-queries/" title="Some patents and some white papers focus upon search queries, and how a search engine might respond to what a searcher might be looking for, and help to fulfill the informational and situational needs they might have.

It is often tempting to think of search queries in terms of the intent behind them, whether they are informational, transactional or navigational.  I recommend that people read the paper A Taxonomy of Web Search by Andrei Broder (who is now at Google) to learn more about the intents behind Search Queries.

With the Web becoming more Semantic and being more about finding entities, it&#039;s possible that looking at search queries to see if they trigger the appearance of an answer box or a featured snippet will become more common.">Search Queries</a>
</li>
<li class="cat-item cat-item-395"><a href="http://www.seobythesea.com/category/semantic-search/" title="The inventor of the Web, Tim Berners-Lee came out with a revision of his original vision of the Web when he started writing about the Semantic Web.  He published an article in Scientific American about The Semantic Web, which is recommended reading.  

Search on the Web has been evolving to focus more on showing results that finds things, instead of strings, or matching keywords within queries to keywords on documents on the web.

This is seen in Google&#039;s original fact repository, followed by their knowledge graph, and Microsoft&#039;s concept graph.  Google, Bing, Yahoo, and Yandex all are followers of schema.org structured data markup, and it can be used to show rich results in search results.">Semantic Search</a>
</li>
<li class="cat-item cat-item-31"><a href="http://www.seobythesea.com/category/small-business/">Small Business</a>
</li>
<li class="cat-item cat-item-16"><a href="http://www.seobythesea.com/category/social-search/">Social Media and Social Search</a>
</li>
<li class="cat-item cat-item-1"><a href="http://www.seobythesea.com/category/uncategorized/">Uncategorized</a>
</li>
<li class="cat-item cat-item-7"><a href="http://www.seobythesea.com/category/usability/">Usability</a>
</li>
<li class="cat-item cat-item-20"><a href="http://www.seobythesea.com/category/web-spam/" title="The Search Engines face many site owners who may try to manipulate search results and have their pages rank higher than their competitors.
This is often known as Web Spam, and the search engines file patents and write papers that describe how they may fight against manipulation of results.">Web Spam</a>
</li>
</ul>
</section><section id="archives-6" class="widget widget_archive"><h2 class="widget-title">Archives</h2> <ul>
<li><a href='http://www.seobythesea.com/2018/10/'>October 2018</a></li>
<li><a href='http://www.seobythesea.com/2018/07/'>July 2018</a></li>
<li><a href='http://www.seobythesea.com/2018/06/'>June 2018</a></li>
<li><a href='http://www.seobythesea.com/2018/04/'>April 2018</a></li>
<li><a href='http://www.seobythesea.com/2018/03/'>March 2018</a></li>
<li><a href='http://www.seobythesea.com/2018/02/'>February 2018</a></li>
<li><a href='http://www.seobythesea.com/2018/01/'>January 2018</a></li>
<li><a href='http://www.seobythesea.com/2017/12/'>December 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/11/'>November 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/10/'>October 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/09/'>September 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/08/'>August 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/06/'>June 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/05/'>May 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/04/'>April 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/03/'>March 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/02/'>February 2017</a></li>
<li><a href='http://www.seobythesea.com/2017/01/'>January 2017</a></li>
<li><a href='http://www.seobythesea.com/2016/12/'>December 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/11/'>November 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/10/'>October 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/09/'>September 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/08/'>August 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/07/'>July 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/06/'>June 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/05/'>May 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/04/'>April 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/03/'>March 2016</a></li>
<li><a href='http://www.seobythesea.com/2016/01/'>January 2016</a></li>
<li><a href='http://www.seobythesea.com/2015/12/'>December 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/11/'>November 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/10/'>October 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/09/'>September 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/08/'>August 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/07/'>July 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/06/'>June 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/05/'>May 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/04/'>April 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/03/'>March 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/02/'>February 2015</a></li>
<li><a href='http://www.seobythesea.com/2015/01/'>January 2015</a></li>
<li><a href='http://www.seobythesea.com/2014/12/'>December 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/11/'>November 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/10/'>October 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/09/'>September 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/08/'>August 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/07/'>July 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/06/'>June 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/05/'>May 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/04/'>April 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/03/'>March 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/02/'>February 2014</a></li>
<li><a href='http://www.seobythesea.com/2014/01/'>January 2014</a></li>
<li><a href='http://www.seobythesea.com/2013/12/'>December 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/11/'>November 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/10/'>October 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/09/'>September 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/08/'>August 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/07/'>July 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/06/'>June 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/05/'>May 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/04/'>April 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/03/'>March 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/02/'>February 2013</a></li>
<li><a href='http://www.seobythesea.com/2013/01/'>January 2013</a></li>
<li><a href='http://www.seobythesea.com/2012/12/'>December 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/11/'>November 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/10/'>October 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/09/'>September 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/08/'>August 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/07/'>July 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/06/'>June 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/05/'>May 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/04/'>April 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/03/'>March 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/02/'>February 2012</a></li>
<li><a href='http://www.seobythesea.com/2012/01/'>January 2012</a></li>
<li><a href='http://www.seobythesea.com/2011/12/'>December 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/11/'>November 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/10/'>October 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/09/'>September 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/08/'>August 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/07/'>July 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/06/'>June 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/05/'>May 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/04/'>April 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/03/'>March 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/02/'>February 2011</a></li>
<li><a href='http://www.seobythesea.com/2011/01/'>January 2011</a></li>
<li><a href='http://www.seobythesea.com/2010/12/'>December 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/11/'>November 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/10/'>October 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/09/'>September 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/08/'>August 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/07/'>July 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/06/'>June 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/05/'>May 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/04/'>April 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/03/'>March 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/02/'>February 2010</a></li>
<li><a href='http://www.seobythesea.com/2010/01/'>January 2010</a></li>
<li><a href='http://www.seobythesea.com/2009/12/'>December 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/11/'>November 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/10/'>October 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/09/'>September 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/08/'>August 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/07/'>July 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/06/'>June 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/05/'>May 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/04/'>April 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/03/'>March 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/02/'>February 2009</a></li>
<li><a href='http://www.seobythesea.com/2009/01/'>January 2009</a></li>
<li><a href='http://www.seobythesea.com/2008/12/'>December 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/11/'>November 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/10/'>October 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/09/'>September 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/08/'>August 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/07/'>July 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/06/'>June 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/05/'>May 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/04/'>April 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/03/'>March 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/02/'>February 2008</a></li>
<li><a href='http://www.seobythesea.com/2008/01/'>January 2008</a></li>
<li><a href='http://www.seobythesea.com/2007/12/'>December 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/11/'>November 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/10/'>October 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/09/'>September 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/08/'>August 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/07/'>July 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/06/'>June 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/05/'>May 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/04/'>April 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/03/'>March 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/02/'>February 2007</a></li>
<li><a href='http://www.seobythesea.com/2007/01/'>January 2007</a></li>
<li><a href='http://www.seobythesea.com/2006/12/'>December 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/11/'>November 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/10/'>October 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/09/'>September 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/08/'>August 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/07/'>July 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/06/'>June 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/05/'>May 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/04/'>April 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/03/'>March 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/02/'>February 2006</a></li>
<li><a href='http://www.seobythesea.com/2006/01/'>January 2006</a></li>
<li><a href='http://www.seobythesea.com/2005/12/'>December 2005</a></li>
<li><a href='http://www.seobythesea.com/2005/11/'>November 2005</a></li>
<li><a href='http://www.seobythesea.com/2005/10/'>October 2005</a></li>
<li><a href='http://www.seobythesea.com/2005/09/'>September 2005</a></li>
<li><a href='http://www.seobythesea.com/2005/06/'>June 2005</a></li>
</ul>
</section> </div>
</aside>
</div>
<aside id="secondary" class="sidebar widget-area" role="complementary">
<section id="search-7" class="widget widget_search">
<form role="search" method="get" class="search-form" action="http://www.seobythesea.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<button type="submit" class="search-submit"><span class="screen-reader-text">Search</span></button>
</form>
</section><section id="text-371989259" class="widget widget_text"> <div class="textwidget"><div id="google_translate_element"></div>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({
    pageLanguage: 'en'
  }, 'google_translate_element');
}
</script><script src="http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit" type="text/javascript"></script></p>
</div>
</section><section id="text-371989258" class="widget widget_text"> <div class="textwidget"><p>SEO by the Sea focuses upon SEO as the search engines tell us about it, from sources such as patents and white papers from the search engines. This information about SEO is tempered by years of experience from the author of the site, who has been doing SEO since the days when search engines started appearing on the Web.</p>
<p><a href="http://www.seobythesea.com/" style="text-decoration: none;"><span style="background: #fff; padding: 1px; font-family: georgia, arial, sans-serif; font-size: x-small; border: 1px solid #aaa;"><span style="color: #f8f8f8; background: #669933; padding: 0px 4px;">SEO</span><span style="color: #000; background: #fff; padding: 0px 10px 0px 3px;">by the Sea</span></span></a></p>
<p><img src="http://www.seobythesea.com/wp-content/Bill-Slawski-June-2018-e1531463278400.jpg" width="100" height="100" alt="Bill Slawski, President of SEO by the Sea" /></p>
<p>Follow Bill Slawski at:</p>
<div><a href="https://www.facebook.com/bill.slawski" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/facebook.png" alt="Follow Us on Facebook" /></a><br />
<a href="https://plus.google.com/+BillSlawski" rel="publisher" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/googleplus.png" alt="Follow Us on Google+" /></a><br />
<a href="http://twitter.com/bill_slawski" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/twitter.png" alt="Follow Us on Twitter" /></a><br />
<a href="https://www.linkedin.com/in/slawski" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/linkedin.png" alt="Follow Us on LinkedIn" title="Follow Us on LinkedIn" /></a></div>
<p>To find out about internet marketing, consulting and <span itemprop="description"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/">SEO services</a></span>, for your site or business <a href="http://www.seobythesea.com/contact-us/">contact</a><br />
Bill Slawski at:</p>
<div itemscope itemtype="http://schema.org/PostalAddress">
<span itemprop="name">SEO by the Sea</span><br />
<span itemprop="addressLocality">Carlsbad</span>, <span itemprop="addressRegion">Ca</span> <span itemprop="postalCode">92009</span>
</div>
<p>Tel: 1 (442) 244-0941<br />
M-F, 9am &#8211; 5pm (pst)</p>
<p>I am the Director of SEO Research at Go Fish Digital. Contact us at <a href="https://gofishdigital.com/">Go Fish Digital</a>:<br />
<a href="https://gofishdigital.com/"><img src="http://www.seobythesea.com/wp-content/gofishdigital-logo.jpg" width="191" height="120" alt="Go Fish Digital" /></a></p>
<p>(703) -531-7775 (9:00am-5:00pm est.)</p>
<div class="g-page" data-width="280" data-href="http://plus.google.com/108421660453447189832" data-rel="publisher"></div>
<section id="text-371989254" class="widget widget_text">
<div class="widget-wrap">
<div class="textwidget">
</div>
</div>
</section>
</div>
</section><section id="text-371989256" class="widget widget_text"> <div class="textwidget"><p>Follow us at:</p>
<div><a href="https://www.facebook.com/SEO-by-the-Sea-121115417920156/" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/facebook.png" alt="Follow Us on Facebook" /></a><br />
<a href="https://plus.google.com/+Seobythesea/posts" rel="publisher" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/googleplus.png" alt="Follow Us on Google+" /></a><br />
<a href="http://twitter.com/seobythesea" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/twitter.png" alt="Follow Us on Twitter" /></a><br />
<a href="http://feeds.feedburner.com/seobythesea/Tesr" rel="nofollow" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/rss.png" alt="Follow Our Feed" title="Follow Us on RSS" /></a><br />
<a href="https://www.linkedin.com/company/224939" target="_blank"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/linkedin.png" alt="Follow Us on LinkedIn" title="Follow Us on LinkedIn" /></a></div>
</div>
</section><section id="text-371989257" class="widget widget_text"> <div class="textwidget"><p><br />
<br />
<script type="text/javascript">
/* < ![CDATA[ */
var google_conversion_id = 998702369;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script><br />
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script><br />
<noscript></p>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/998702369/?guid=ON&#038;script=0"/>
</div>
<p></noscript></p>
</div>
</section><section id="text-371989255" class="widget widget_text"> <div class="textwidget"><p>Is your site Seaworthy?</p>
<p><img src="http://www.seobythesea.com/wp-content/Seaworthy.jpg" width="275" Height="475" /></p>
<p>Look into getting an <a href="http://www.seobythesea.com/services-from-seo-by-the-sea/seo-site-audit-and-recommendations/">SEO Site Audit</a></p>
</div>
</section><section id="meta-10" class="widget widget_meta"><h2 class="widget-title">Meta</h2> <ul>
<li><a rel="nofollow" href="http://www.seobythesea.com/wp-login.php">Log in</a></li>
<li><a href="http://www.seobythesea.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
<li><a href="http://www.seobythesea.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li> </ul>
</section><section id="linkcat-45" class="widget widget_links"><h2 class="widget-title"> Find Me At:</h2>
<ul class='xoxo blogroll'>
<li><a href="https://about.me/billslawski">About Me &#8211; Bill Slawski</a></li>
<li><a href="https://plus.google.com/+SeobytheseaBogusHangout" rel="me">Bill and Ammon&#039;s Bogus Hangout</a></li>
<li><a href="https://www.crunchbase.com/person/bill-slawski#/entity">Bill Slawski &#8211; Crunchbase</a></li>
<li><a href="https://www.pubcon.com/bios/bill_slawski.htm">Bill Slawski &#8211; Pubcon</a></li>
<li><a href="https://www.slideshare.net/billslawski" rel="me">Bill Slawski &#8211; Slideshare</a></li>
<li><a href="https://medium.com/@bill_slawski">Bill Slawski on Medium</a></li>
<li><a href="https://gofishdigital.com/author/bill/">Bill Slawski&#039;s Go Fish Digital Posts</a></li>
<li><a href="https://moz.com/community/users/2357">Bill Slawski&#039;s Moz Profile</a></li>
<li><a href="https://www.pinterest.com/billslawski/" rel="me">Bill Slawski&#039;s Pinterest</a></li>
<li><a href="http://carlsbadcal.com">carlsbadcal</a></li>
<li><a href="https://www.facebook.com/bill.slawski">facebook &#8211; bill slawski</a></li>
<li><a href="http://www.facebook.com/pages/SEO-by-the-Sea/121115417920156" rel="me">facebook &#8211; seo by the sea</a></li>
<li><a href="https://www.flickr.com/photos/bragadocchio/" rel="me">flickr &#8211; bill slawski</a></li>
<li><a href="https://plus.google.com/+BillSlawski">Google+ &#8211; Bill Slawski</a></li>
<li><a href="https://www.instagram.com/billslawski/" rel="me">instagram &#8211; Bill Slawski</a></li>
<li><a href="https://www.meetup.com/Semantic-Web-San-Diego/">lotico san diego semantic web</a></li>
<li><a href="https://moz.com/blog">moz &#8211; bill slawski</a></li>
<li><a href="https://www.quora.com/profile/Bill-Slawski">Quora &#8211; Bill Slawski</a></li>
<li><a href="https://searchenginewatch.com/author/bill-slawski/">Search Engine Watch &#8211; Bill Slawski</a></li>
<li><a href="https://searchnewscentral.com/blog/author/billslawski/">Search News Central Bill Slawski Profile</a></li>
<li><a href="https://searchengineland.com/author/bill-slawski">searchengineland &#8211; bill slawski</a></li>
<li><a href="https://www.pinterest.com/billslawski/" rel="me">SEO by the Sea Pinterest Board</a></li>
<li><a href="https://twitter.com/bill_slawski" rel="me">twitter &#8211; Bill Slawski</a></li>
<li><a href="https://www.youtube.com/user/bragadocchio" rel="me">Youtube &#8211; bill slawski</a></li>
</ul>
</section>
<section id="linkcat-39" class="widget widget_links"><h2 class="widget-title">Audio / Video</h2>
<ul class='xoxo blogroll'>
<li><a href="https://www.ted.com/">ted: ideas worth spreading</a></li>
<li><a href="http://videolectures.net/">videolectures.net</a></li>
<li><a href="https://www.youtube.com/user/Google">youtube google channel</a></li>
<li><a href="https://www.youtube.com/user/googletechtalks?ob=4">youtube google tech talks</a></li>
</ul>
</section>
<section id="linkcat-32" class="widget widget_links"><h2 class="widget-title">Blogroll</h2>
<ul class='xoxo blogroll'>
<li><a href="https://www.allthingsweb.co.uk/blog/">all things web</a></li>
<li><a href="https://blog.arhg.net/" rel="friend">andrew girdwood</a></li>
<li><a href="http://codingplayground.blogspot.com/">antonio gulli&#039;s coding playground</a></li>
<li><a href="https://www.billhartzer.com/">bill hartzer</a></li>
<li><a href="http://www.blindfiveyearold.com/">blind five year old</a></li>
<li><a href="https://www.buzzmaven.com/">buzzmaven &#8211; scott clark</a></li>
<li><a href="https://clickfire.com/">clickfire</a></li>
<li><a href="http://www.daviddalka.com/createvalue/">david dalka</a></li>
<li><a href="http://www.delawarebusinessblog.com/" rel="friend">delaware business blog</a></li>
<li><a href="https://evolvor.com/">eric herbert</a></li>
<li><a href="https://ai.googleblog.com/">Google AI Blog</a></li>
<li><a href="https://www.ranksense.com/">hamlet batista</a></li>
<li><a href="https://www.hobo-web.co.uk/">hobo seo</a></li>
<li><a href="http://ipullrank.com/">ipullrank</a></li>
<li><a href="https://www.mattcutts.com/blog/">matt cutts: gadgets, google, and seo</a></li>
<li><a href="https://www.notprovided.eu/" rel="friend colleague">notprovided.eu</a></li>
<li><a href="https://blog.ouseful.info/">ouseful.info, the blog…</a></li>
<li><a href="http://www.reubenyau.com/">reuben yau</a></li>
<li><a href="https://rob.bertholf.com/">rob bertholf</a></li>
<li><a href="http://www.searchengineguide.com/">search engine guide</a></li>
<li><a href="https://searchengineland.com/">search engine land</a></li>
<li><a href="https://www.slideshare.net/SanDiegoSemanticWeb">semantic web slideshare</a></li>
<li><a href="http://www.seodesignsolutions.com/blog/">seo design solutions</a></li>
<li><a href="http://www.seoskeptic.com/" rel="friend met colleague">seo skeptic</a></li>
<li><a href="https://www.seo-theory.com/">seo theory</a></li>
<li><a href="http://www.seopittfall.com/">seopittfall</a></li>
<li><a href="https://vanseodesign.com/blog/">thevanblog</a></li>
<li><a href="http://blumenthals.com/blog/" rel="friend">understanding google maps and local search</a></li>
<li><a href="http://www.yackyack.co.uk/">yack yack</a></li>
</ul>
</section>
<section id="linkcat-46" class="widget widget_links"><h2 class="widget-title">Design and Usability</h2>
<ul class='xoxo blogroll'>
<li><a href="https://www.uie.com/">User Interface Engineering</a></li>
<li><a href="https://www.uxmatters.com/">ux matters</a></li>
</ul>
</section>
</aside>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<nav class="main-navigation" role="navigation" aria-label="Footer Primary Menu">
<div class="menu-sitepages-container"><ul id="menu-sitepages-1" class="primary-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12176"><a href="http://www.seobythesea.com">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11759"><a href="http://www.seobythesea.com/faq/">FAQ</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4296"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/">Services</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14179"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/local-search-seo/">Local SEO Services</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14181"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/seo-site-audit-and-recommendations/">SEO Audit</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14180"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/seo-training-and-coaching/">SEO Training and Coaching</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14193"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/link-building-strategies/">Link Building Strategies</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14182"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/keyword-research/">Keyword Research</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4298"><a href="http://www.seobythesea.com/about-seo-by-the-sea/">About</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17899"><a href="http://www.seobythesea.com/seo-testimonials/">SEO Testimonials</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4299"><a href="http://www.seobythesea.com/recommended-seo-and-usability-reading/">Resources</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13402"><a href="http://www.seobythesea.com/recommended-seo-and-usability-reading/semantic-web-resources/">Semantic Web Resources</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4297"><a href="http://www.seobythesea.com/contact-us/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4294"><a href="http://www.seobythesea.com/subscribe/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11622"><a href="http://www.seobythesea.com/privacy-policy/">Privacy</a></li>
</ul></div> </nav>
<div class="site-info">
<span class="site-title"><a href="http://www.seobythesea.com/" rel="home">SEO by the Sea &#9875;</a></span>
<a href="https://wordpress.org/" class="imprint">
Proudly powered by WordPress </a>
</div>
</footer>
</div>
</div>
<script type='text/javascript' src='http://www.seobythesea.com/wp-content/plugins/anti-spam/js/anti-spam-5.2.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.seobythesea.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.5'></script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-content/themes/twentysixteen/js/skip-link-focus-fix.js?ver=20160816'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-content/themes/twentysixteen/js/functions.js?ver=20160816'></script>
<script type='text/javascript' src='http://www.seobythesea.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script async="async" type='text/javascript' src='http://www.seobythesea.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>
</body>
</html>
