<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><link rel="profile" href="https://gmpg.org/xfn/11"><title>PageRank 2020 - SEO by the Sea &#9875;</title> <script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '7117a2443e8ab69c93f632c2ddbf995712c34464c4646874409f792a2fb8291d', '0');</script> <meta name="description" content="A new whitepaper will be presented at the WWW &#039;20 conference about PageRank by a Google Software engineer, who wrote it while he was at Yahoo." /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="http://www.seobythesea.com/2020/04/pagerank-2020/" /> <meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="PageRank 2020" /><meta property="og:description" content="A new whitepaper will be presented at the WWW &#039;20 conference about PageRank by a Google Software engineer, who wrote it while he was at Yahoo." /><meta property="og:url" content="http://www.seobythesea.com/2020/04/pagerank-2020/" /><meta property="og:site_name" content="SEO by the Sea &#9875;" /><meta property="og:updated_time" content="2020-04-07T07:26:13+00:00" /><meta property="article:published_time" content="2020-04-02T15:46:18+00:00" /><meta property="article:modified_time" content="2020-04-07T07:26:13+00:00" /><meta property="og:image" content="http://www.seobythesea.com/wp-content/new-york-public-library.jpg" /><meta property="og:image:width" content="450" /><meta property="og:image:height" content="669" /><meta property="article:author" content="https://www.facebook.com/bill.slawski" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:title" content="PageRank 2020" /><meta name="twitter:description" content="A new whitepaper will be presented at the WWW &#039;20 conference about PageRank by a Google Software engineer, who wrote it while he was at Yahoo." /><meta name="twitter:image" content="http://www.seobythesea.com/wp-content/new-york-public-library.jpg" /><meta name="twitter:creator" content="@bill_slawski" />  <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.seobythesea.com/#website","url":"http://www.seobythesea.com/","name":"SEO by the Sea &#9875;","inLanguage":"en-US","description":"Learn SEO Directly from the Search Engines","potentialAction":[{"@type":"SearchAction","target":"http://www.seobythesea.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"http://www.seobythesea.com/2020/04/pagerank-2020/#primaryimage","inLanguage":"en-US","url":"http://www.seobythesea.com/wp-content/new-york-public-library.jpg","width":450,"height":669,"caption":"New York Public Library"},{"@type":"WebPage","@id":"http://www.seobythesea.com/2020/04/pagerank-2020/#webpage","url":"http://www.seobythesea.com/2020/04/pagerank-2020/","name":"PageRank 2020 - SEO by the Sea &#9875;","isPartOf":{"@id":"http://www.seobythesea.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"http://www.seobythesea.com/2020/04/pagerank-2020/#primaryimage"},"datePublished":"2020-04-02T22:46:18+00:00","dateModified":"2020-04-07T14:26:13+00:00","author":{"@id":"http://www.seobythesea.com/#/schema/person/e31745404a3b75f291e265c5fa06ddba"},"description":"A new whitepaper will be presented at the WWW '20 conference about PageRank by a Google Software engineer, who wrote it while he was at Yahoo.","breadcrumb":{"@id":"http://www.seobythesea.com/2020/04/pagerank-2020/#breadcrumb"},"potentialAction":[{"@type":"ReadAction","target":["http://www.seobythesea.com/2020/04/pagerank-2020/"]}]},{"@type":"BreadcrumbList","@id":"http://www.seobythesea.com/2020/04/pagerank-2020/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"http://www.seobythesea.com/","url":"http://www.seobythesea.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"http://www.seobythesea.com/category/seo/","url":"http://www.seobythesea.com/category/seo/","name":"Search Engine Optimization (SEO)"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"http://www.seobythesea.com/2020/04/pagerank-2020/","url":"http://www.seobythesea.com/2020/04/pagerank-2020/","name":"PageRank 2020"}}]},{"@type":["Person"],"@id":"http://www.seobythesea.com/#/schema/person/e31745404a3b75f291e265c5fa06ddba","name":"Bill Slawski","sameAs":["https://www.facebook.com/bill.slawski","https://twitter.com/@bill_slawski"]}]}</script> <link rel="alternate" type="application/rss+xml" title="SEO by the Sea &#9875; &raquo; Feed" href="http://www.seobythesea.com/feed/" /><link rel="alternate" type="application/rss+xml" title="SEO by the Sea &#9875; &raquo; Comments Feed" href="http://www.seobythesea.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="SEO by the Sea &#9875; &raquo; PageRank 2020 Comments Feed" href="http://www.seobythesea.com/2020/04/pagerank-2020/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-6258590-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-6258590-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <link rel='stylesheet' id='siteground-optimizer-combined-styles-header-css' href='http://www.seobythesea.com/wp-content/siteground-optimizer-assets/siteground-optimizer-combined-styles-3473b693f2c4977ddaf2ab323793dde6.min.css' type='text/css' media='all' /><style id='siteground-optimizer-combined-styles-header-inline-css' type='text/css'>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</style> <script type='text/javascript'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"http:\/\/www.seobythesea.com","hash_tracking":"false"};
/* ]]> */</script> <script defer type='text/javascript' src='http://www.seobythesea.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js'></script> <script type='text/javascript' src='http://www.seobythesea.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='http://www.seobythesea.com/wp-includes/js/jquery/jquery-migrate.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"e389a99977","_ajax_url":"http:\/\/www.seobythesea.com\/wp-admin\/admin-ajax.php"};
/* ]]> */</script> <script defer type='text/javascript' async="async" src='http://www.seobythesea.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var ctNocache = {"ajaxurl":"http:\/\/www.seobythesea.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"http:\/\/www.seobythesea.com\/"};
/* ]]> */</script> <script defer type='text/javascript' async="async" src='http://www.seobythesea.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js'></script> <link rel='https://api.w.org/' href='http://www.seobythesea.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.seobythesea.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.seobythesea.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='http://www.seobythesea.com/?p=28037' /><link rel="alternate" type="application/json+oembed" href="http://www.seobythesea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.seobythesea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F&#038;format=xml" />  <script async src="https://www.googletagmanager.com/gtag/js?id=AW-998702369"></script> <script>window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date()); gtag('config', 'AW-998702369');</script><script>function breakfree() { if ( top.location != self.location ) { top.location = self.location; } }window.onload = breakfree();</script><style type="text/css" data-source="Grow by Mediavine"></style><meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="http://www.seobythesea.com/wp-content/favicon.bmp" sizes="32x32" /><link rel="icon" href="http://www.seobythesea.com/wp-content/favicon.bmp" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="http://www.seobythesea.com/wp-content/favicon.bmp" /><meta name="msapplication-TileImage" content="http://www.seobythesea.com/wp-content/favicon.bmp" /></head><body class="post-template-default single single-post postid-28037 single-format-standard wp-embed-responsive right-sidebar nav-below-header fluid-header separate-containers active-footer-widgets-3 nav-aligned-left header-aligned-left dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope> <a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a><header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope><div class="inside-header grid-container grid-parent"><div class="site-branding"><p class="main-title" itemprop="headline"> <a href="http://www.seobythesea.com/" rel="home"> SEO by the Sea &#9875; </a></p><p class="site-description" itemprop="description"> Learn SEO Directly from the Search Engines</p></div></div></header><nav id="site-navigation" class="main-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope><div class="inside-navigation grid-container grid-parent"> <button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false"> <span class="mobile-menu">Menu</span> </button><div id="primary-menu" class="main-nav"><ul id="menu-sitepages" class=" menu sf-menu"><li id="menu-item-12176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12176"><a href="http://www.seobythesea.com">Blog</a></li><li id="menu-item-11759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11759"><a href="http://www.seobythesea.com/faq/">FAQ</a></li><li id="menu-item-4296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4296"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/">SEO Services<span role="presentation" class="dropdown-menu-toggle"></span></a><ul class="sub-menu"><li id="menu-item-14179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14179"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/local-search-seo/">Local Search Services</a></li><li id="menu-item-14181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14181"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/seo-site-audit-and-recommendations/">SEO Audit</a></li><li id="menu-item-14180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14180"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/seo-training-and-coaching/">SEO Training and Coaching</a></li><li id="menu-item-14193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14193"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/link-building-strategies/">Link Building Strategies</a></li><li id="menu-item-14182" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14182"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/keyword-research/">Keyword Research</a></li></ul></li><li id="menu-item-4298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4298"><a href="http://www.seobythesea.com/about-seo-by-the-sea/">About<span role="presentation" class="dropdown-menu-toggle"></span></a><ul class="sub-menu"><li id="menu-item-26091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26091"><a href="http://www.seobythesea.com/sitemap/">Sitemap</a></li></ul></li><li id="menu-item-4299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4299"><a href="http://www.seobythesea.com/recommended-seo-and-usability-reading/">Resources<span role="presentation" class="dropdown-menu-toggle"></span></a><ul class="sub-menu"><li id="menu-item-13402" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13402"><a href="http://www.seobythesea.com/recommended-seo-and-usability-reading/semantic-web-resources/">Semantic Marketing Resources (Updated)</a></li></ul></li><li id="menu-item-4297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4297"><a href="http://www.seobythesea.com/contact-us/">Contact SEO by the Sea</a></li><li id="menu-item-4294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4294"><a href="http://www.seobythesea.com/subscribe/">Subscribe</a></li><li id="menu-item-11622" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-11622"><a href="http://www.seobythesea.com/privacy-policy/">Privacy</a></li></ul></div></div></nav><div id="page" class="hfeed site grid-container container grid-parent"><div id="content" class="site-content"><div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75"><main id="main" class="site-main"><article id="post-28037" class="post-28037 post type-post status-publish format-standard has-post-thumbnail hentry category-seo" itemtype="https://schema.org/CreativeWork" itemscope><div class="inside-article"><div class="page-header-image-single grid-container grid-parent"> <img width="450" height="669" src="http://www.seobythesea.com/wp-content/new-york-public-library.jpg" class="attachment-full size-full wp-post-image" alt="New York Public Library" itemprop="image" srcset="http://www.seobythesea.com/wp-content/new-york-public-library.jpg 450w, http://www.seobythesea.com/wp-content/new-york-public-library-202x300.jpg 202w" sizes="(max-width: 450px) 100vw, 450px" /></div><header class="entry-header"><h1 class="entry-title" itemprop="headline">PageRank 2020</h1><div class="entry-meta"> <span class="posted-on"><a href="http://www.seobythesea.com/2020/04/pagerank-2020/" title="3:46 pm" rel="bookmark"><time class="updated" datetime="2020-04-07T07:26:13-07:00" itemprop="dateModified">04/07/2020</time><time class="entry-date published" datetime="2020-04-02T15:46:18-07:00" itemprop="datePublished">04/02/2020</time></a></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="http://www.seobythesea.com/author/billbill/" title="View all posts by Bill Slawski" rel="author" itemprop="url"><span class="author-name" itemprop="name">Bill Slawski</span></a></span></span></div></header><div class="entry-content" itemprop="text"><p class="dpsp-share-text ">Sharing is caring!</p><div id="dpsp-content-top" class="dpsp-content-wrapper dpsp-shape-rounded dpsp-size-small dpsp-has-spacing dpsp-has-buttons-count dpsp-show-on-mobile dpsp-show-total-share-count dpsp-show-total-share-count-after dpsp-button-style-2"><div class="dpsp-total-share-wrapper"><span class="dpsp-icon-total-share"></span><span class="dpsp-total-share-count">29</span><span>shares</span></div><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content dpsp-networks-btns-share dpsp-column-auto dpsp-has-button-icon-animation"><li><a rel="nofollow noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F&t=PageRank%202020" class="dpsp-network-btn dpsp-facebook dpsp-first"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Facebook</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://twitter.com/intent/tweet?text=PageRank%202020&url=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F" class="dpsp-network-btn dpsp-twitter dpsp-has-count"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Twitter</span><span class="dpsp-network-count">29</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://www.linkedin.com/shareArticle?url=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F&title=PageRank%202020&summary=If%20you%20have%20been%20working%20as%20an%20SEO%20for%20any%20amount%20of%20time%2C%20or%20have%20been%20responsible%20for%20marketing%20a%20website%2C%20it%27s%20possible%20that%20you%20have%20heard%20of%20PageRank%2C%20which%20was%20developed%20by%20the%20Founders&mini=true" class="dpsp-network-btn dpsp-linkedin"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">LinkedIn</span></span></a></li><li><a rel="nofollow noopener noreferrer" data-href="#" class="dpsp-network-btn dpsp-pinterest dpsp-last"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Pinterest</span></span></a></li></ul></div><span id="dpsp-post-content-markup" data-image-pin-it="false"></span><p>If you have been working as an SEO for any amount of time, or have been responsible for marketing a website, it&#8217;s possible that you have heard of PageRank, which was developed by the Founders of Google in the earliest days of the Search Engine. There is some new news concerning PageRank that I wanted to share when I learned about it this morning.</p><p>You may have heard a little about the history of the PageRank algorithm, and that <a href="https://news.ycombinator.com/item?id=20440079">Google had stopped using</a> at least the original version of PageRank back in 2006. Or that they started using a version of PageRank (still referred to as PageRank) after that time. It&#8217;s possible that they started using a different version of PageRank at that time. There have been at least two others developed by Google that were available in 2006.</p><p>The original patent behind PageRank was originally assigned to Stanford University, where Lawrence Page and Sergey Brin were both students who started working on a search engine, as a diversion while their Ph.D. Supervisor went on Sabbatical to Japan for a year.</p><p>A provisional Patent from Lawrence Page was the first official document that described how the search engine worked using the PageRank algorithm. I found a copy of the provisional patent behind PageRank on the USPTO website which I blogged about in 2011. That provisional patent was <a href="http://www.seobythesea.com/improved-text-searching-in-hypertext-systems.pdf">Improved Text Searching in Hypertext Systems</a> (pdf – 1.7mb). In that version of the patent, Page referred to PageRank as &#8220;An Approximating to &#8216;Importance'&#8221; In other words, PageRank is an &#8220;approximation of how well-cited or important&#8221; matching documents for a query might be.</p><p>Google filed a patent <a href="http://www.seobythesea.com/2018/04/pagerank-updated/">updating PageRank</a> October 12, 2006 for the first time (it was updated since at least once.) Another version of PageRank was written about by researchers at Google that resulted in a version that was considered more efficient in the paper <a href="http://ilpubs.stanford.edu:8090/386/1/1999-31.pdf">Efficient Computation of PageRank</a>. Other papers have been written about PageRank as well.</p><p>The original patent behind PageRank assigned to Stanford University and which was exclusively licensed to Google has likely expired in 2018. Which has meant that Search Engines other than Google could use PageRank. Chances are that the PageRank described in the early patents from Stanford, and even the later patents and papers from Google has changed as it was used to rank pages on the Web.</p><p>I took a look at the <a href="https://research.google/pubs/?year=2020">Google Research Publications from 2020</a> this morning, and came across a paper titled <a href="https://research.google/pubs/pub48942/">Scaling PageRank to 100 Billion Pages</a> while the author was an employee at Yahoo. He is at Google now, and his name is <a href="https://www.linkedin.com/in/stergios-stergiou-3584a012/" class="broken_link">Stergios Stergiou</a>.</p><p>He tells us in his LinkedIn profile that he has:</p><p>Architected and implemented many massively distributed systems, including:</p><ul><li>A Word2Vec algorithm that learns from a 1 trillion words corpus in 2 hours per epoch</li><li>A PageRank algorithm that executes 35&#8243; iterations on a 3 trillion edges web graph</li><li>A Set Cover algorithm capable of processing 1 trillion elements in 20 billion sets</li><li>A Connected Components algorithm able to process a 5.9 trillion edge graph in 3808</li></ul><p>That list item about PageRank matches up with the paper that he authored while at Yahoo!, and he may have experimented with that while at Yahoo, which his profile says that he left in October of 2017. He now works as a Software Engineer at Google.</p><p>We have no knowledge of whether or not he has worked on PageRank after joining Google, after leaving Yahoo, but it was interesting seeing the paper in the Google Research publications section.</p><p>It is possible that it wouldn&#8217;t be there if he hadn&#8217;t joined Google, and we may never learn if the approaches behind PageRank described in that paper have been put into place at Google.</p><p>We also don&#8217;t know if the PageRank that he was writing about in that paper was like the one in use at Google when it was written.</p><p>However the paper is included in papers to be presented at <a href="https://www2020.thewebconf.org/">WWW ’20</a>, April 20–24, 2020, Taipei, Taiwan. According to the conference Website, it will still be held but will be online only.</p><p>I am not going to make any assumptions about the use of the processes described in the paper. The crawl data listed in it is cited as being from 2016, and some newer information in the footnotes of the paper are from 2020, such as a page on the Google site, about how Crawling and Indexing work at Google.</p><p>We have been told by Google Spokespeople that <a href="https://www.seroundtable.com/google-still-uses-pagerank-29056.html">Google still uses PageRank</a>. We don&#8217;t know if that version of PageRank is like the <a href="" https: research.google pubs pub48942 ">Scaling PageRank to 100 Billion Pages</a> Version that will be presented in 2-3 weeks at the online WWW conference.</p><p class="dpsp-share-text ">Sharing is caring!</p><div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-rounded dpsp-size-small dpsp-has-spacing dpsp-has-buttons-count dpsp-show-on-mobile dpsp-show-total-share-count dpsp-show-total-share-count-after dpsp-button-style-2"><div class="dpsp-total-share-wrapper"><span class="dpsp-icon-total-share"></span><span class="dpsp-total-share-count">29</span><span>shares</span></div><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content dpsp-networks-btns-share dpsp-column-auto dpsp-has-button-icon-animation"><li><a rel="nofollow noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F&t=PageRank%202020" class="dpsp-network-btn dpsp-facebook dpsp-first"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Facebook</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://twitter.com/intent/tweet?text=PageRank%202020&url=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F" class="dpsp-network-btn dpsp-twitter dpsp-has-count"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Twitter</span><span class="dpsp-network-count">29</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://www.linkedin.com/shareArticle?url=http%3A%2F%2Fwww.seobythesea.com%2F2020%2F04%2Fpagerank-2020%2F&title=PageRank%202020&summary=If%20you%20have%20been%20working%20as%20an%20SEO%20for%20any%20amount%20of%20time%2C%20or%20have%20been%20responsible%20for%20marketing%20a%20website%2C%20it%27s%20possible%20that%20you%20have%20heard%20of%20PageRank%2C%20which%20was%20developed%20by%20the%20Founders&mini=true" class="dpsp-network-btn dpsp-linkedin"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">LinkedIn</span></span></a></li><li><a rel="nofollow noopener noreferrer" data-href="#" class="dpsp-network-btn dpsp-pinterest dpsp-last"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Pinterest</span></span></a></li></ul></div></div><footer class="entry-meta"> <span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://www.seobythesea.com/category/seo/" rel="category tag">Search Engine Optimization (SEO)</a></span> <span class="comments-link"><a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comments">8 Comments</a></span><nav id="nav-below" class="post-navigation"> <span class="screen-reader-text">Post navigation</span><div class="nav-previous"><span class="prev" title="Previous"><a href="http://www.seobythesea.com/2020/03/disambiguating-image-queries/" rel="prev">Disambiguating Image Queries at Google</a></span></div></nav></footer></div></article><div class="comments-area"><div id="comments"><h3 class="comments-title"> 8 thoughts on &ldquo;PageRank 2020&rdquo;</h3><ol class="comment-list"><li id="comment-575737" class="comment even thread-even depth-1"><article id="div-comment-575737" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='https://www.linkedin.com/in/taskosnikos/' rel='external nofollow ugc' class='url'>Nikos</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-575737"> <time datetime="2020-04-03T13:53:33-07:00" itemprop="datePublished"> 04/03/2020 at 1:53 pm </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>Great one and so informative as always!</p></div></article></li><li id="comment-575738" class="comment byuser comment-author-billbill bypostauthor odd alt thread-odd thread-alt depth-1"><article id="div-comment-575738" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='http://www.seobythesea.com' rel='external nofollow ugc' class='url'>Bill Slawski</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-575738"> <time datetime="2020-04-03T14:51:14-07:00" itemprop="datePublished"> 04/03/2020 at 2:51 pm </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>Thank you, Nikos.</p></div></article></li><li id="comment-575752" class="comment even thread-even depth-1"><article id="div-comment-575752" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='https://blog7.org' rel='external nofollow ugc' class='url'>Panagiotis Kontogiannis</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-575752"> <time datetime="2020-04-04T02:15:35-07:00" itemprop="datePublished"> 04/04/2020 at 2:15 am </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>So pagerank he&#8217;s alive but we are already in 2020 and SERP are so complex that this figure is not of the utmost importance.</p></div></article></li><li id="comment-575756" class="comment byuser comment-author-billbill bypostauthor odd alt thread-odd thread-alt depth-1"><article id="div-comment-575756" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='http://www.seobythesea.com' rel='external nofollow ugc' class='url'>Bill Slawski</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-575756"> <time datetime="2020-04-04T08:57:21-07:00" itemprop="datePublished"> 04/04/2020 at 8:57 am </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>Hi Panagiotis,</p><p>The author of the paper wrote it while he was at Yahoo, and he has since left there to go to work at Google. I know from someone who works at Yahoo that the approach described in the paper is one that is in use. It is not PageRank. But it is a graph-based algorithm that is modeled after PageRank. One of the amazing things about it is how much it scales to cover a very large number of pages. Back when Google used to run the older version of PageRank, Google used to update rankings of pages using a batch processing approach every 5 weeks or so. Google moved on from that to an approach that updates rankings in a more real-time way. But it is possible that Google may explore a graph-based approach like the one described In this paper that the author wrote when he was at Yahoo. I took a look to see if he had any patents in his name, and according to LinkedIn he has worked on at least 62. I think it&#8217;s possible that we will see his name appearing on patents from Google in the future, and I will be watching out for them. Some of the earlier ones he has worked on for other companies looked very interesting. So, he wrote about PageRank, but it is a very different PageRank than the one that Lawrence Page invented in the late 90s.</p></div></article></li><li id="comment-575758" class="comment even thread-even depth-1"><article id="div-comment-575758" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='https://pinguisweb.com/' rel='external nofollow ugc' class='url'>James</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-575758"> <time datetime="2020-04-04T17:10:29-07:00" itemprop="datePublished"> 04/04/2020 at 5:10 pm </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>Just a quick note, your webpage is a great insight into the history of ranking mechanisms. Especially the evolution and growth and continual growth, even today.<br /> Thanks</p></div></article></li><li id="comment-575760" class="comment byuser comment-author-billbill bypostauthor odd alt thread-odd thread-alt depth-1"><article id="div-comment-575760" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='http://www.seobythesea.com' rel='external nofollow ugc' class='url'>Bill Slawski</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-575760"> <time datetime="2020-04-04T17:28:19-07:00" itemprop="datePublished"> 04/04/2020 at 5:28 pm </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>Hi James,</p><p>Thanks for your note. There&#8217;s a lot happening all of the time in Search, and it pays to be diligent, and listen, and follow leads about what might be changing, because there is a lot of potential for change.</p></div></article></li><li id="comment-576051" class="comment even thread-even depth-1"><article id="div-comment-576051" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='https://bud.agency' rel='external nofollow ugc' class='url'>Tom</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-576051"> <time datetime="2020-04-06T08:50:11-07:00" itemprop="datePublished"> 04/06/2020 at 8:50 am </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>Fascinating as always Bill.<br /> What do you feel the practical outcomes of scaling the existing PR algo?</p><p>I might be off the mark here but I&#8217;m reading a potentially more dynamic and efficient algo at this scale.</p></div></article></li><li id="comment-576125" class="comment byuser comment-author-billbill bypostauthor odd alt thread-odd thread-alt depth-1"><article id="div-comment-576125" class="comment-body" itemtype="https://schema.org/Comment" itemscope><footer class="comment-meta"><div class="comment-author-info"><div class="comment-author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope> <cite itemprop="name" class="fn"><a href='http://www.seobythesea.com' rel='external nofollow ugc' class='url'>Bill Slawski</a></cite></div><div class="entry-meta comment-metadata"> <a href="http://www.seobythesea.com/2020/04/pagerank-2020/#comment-576125"> <time datetime="2020-04-06T14:35:03-07:00" itemprop="datePublished"> 04/06/2020 at 2:35 pm </time> </a></div></div></footer><div class="comment-content" itemprop="text"><p>Hi Tom,</p><p>This is Yahoo&#8217;s Algorithm, rather than Google&#8217;s. It should be helpful in handling a lot more data about websites and may be able to do it more quickly. I seem to recall reading that it was capable of doing a lot really quickly. I remember the days of Google doing batch updates every 5 weeks or so, and it is good to see that there isn&#8217;t any intent of going back to those days.</p></div></article></li></ol><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/04/pagerank-2020/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+CommentsForSeoByTheSea+%28Comments+for+SEO+by+the+Sea%29#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.seobythesea.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment-ab3e44043775b" cols="45" rows="8" aria-required="true"></textarea><textarea name="comment" rows="1" cols="1" style="display:none"></textarea></p><input type="hidden" name="comment-replaced" value="true" /><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" /> <label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" /> <label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" /><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='28037' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8717f2be49" /></p><div class="wantispam-required-fields"><input type="hidden" name="wantispam_t" class="wantispam-control wantispam-control-t" value="1586452859" /><div class="wantispam-group wantispam-group-q" style="clear: both;"> <label>Current <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7b021e3b09">[email&#160;protected]</a> <span class="required">*</span></label> <input type="hidden" name="wantispam_a" class="wantispam-control wantispam-control-a" value="2020" /> <input type="text" name="wantispam_q" class="wantispam-control wantispam-control-q" value="6.5.4" autocomplete="off" /></div><div class="wantispam-group wantispam-group-e" style="display: none;"> <label>Leave this field empty</label> <input type="text" name="wantispam_e_email_url_website" class="wantispam-control wantispam-control-e" value="" autocomplete="off" /></div></div><p style="display:none;"><input type="text" name="nxts" value="1586452859" /><input type="text" name="nxts_signed" value="6b2991a2551bd0633c378a09603306b6b619fa33" /><input type="text" name="2158b18cb658a4" value="" /><input type="text" name="58af22f75850e71fb7eb010a938" value="2a5b732bfdefa30ba3de79" /></p><input type='hidden' id='ct_checkjs_ffeabd223de0d4eacb9a3e6e53e5448d' name='ct_checkjs' value='0' /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>window.addEventListener('load', function () {setTimeout(function(){                    apbct_sendAJAXRequest(                        {action: 'apbct_js_keys__get'},                        {callback: apbct_js_keys__set_input_value, input_name: 'ct_checkjs_ffeabd223de0d4eacb9a3e6e53e5448d'}                    );                }, 1000);});</script><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="228" /></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div></main></div><div id="right-sidebar" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope><div class="inside-right-sidebar"><aside id="search-2" class="widget inner-padding widget_search"><form method="get" class="search-form" action="http://www.seobythesea.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:"> </label> <input type="submit" class="search-submit" value="Search"></form></aside><aside id="text-371989235" class="widget inner-padding widget_text"><div class="textwidget"><br /><div id="google_translate_element"></div><script type="text/javascript">function googleTranslateElementInit() {
  new google.translate.TranslateElement({
    pageLanguage: 'en'
  }, 'google_translate_element');
}</script><script src="https://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit" type="text/javascript"></script>  <br /><br /> <a href="http://www.seobythesea.com/"><img src="http://www.seobythesea.com/wp-content/logo-seobythesea_12aba31099601d96cdbde2b3c50a1dac.jpg" width="150" height="150" alt="SEO by the Sea logo" /></a> <br /><br /> <img src="http://www.seobythesea.com/wp-content/Bill-Slawski-June-2018-e1531463278400_319f29e4eb13444a50237359d889624b.jpg" width="100" height="100" alt="Bill Slawski, President of SEO by the Sea" /> <br /><br /> Follow Bill Slawski at:<div><a href="https://www.facebook.com/bill.slawski" target="_blank" rel="noopener noreferrer"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/facebook.png" alt="Follow Us on Facebook" style="opacity: 0.8; -moz-opacity: 0.8;" /></a> <a href="https://twitter.com/bill_slawski" target="_blank" rel="noopener noreferrer"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/twitter.png" alt="Follow Us on Twitter" style="opacity: 0.8; -moz-opacity: 0.8;" /></a> <a href="https://www.linkedin.com/in/slawski" target="_blank" rel="noopener noreferrer"><img width="32" height="32" src="http://www.seobythesea.com/wp-images/linkedin.png" alt="Follow Us on LinkedIn" title="Follow Us on LinkedIn" style="opacity: 0.8; -moz-opacity: 0.8;" /></a></div> To find out about internet marketing, consulting and <span itemprop="description"><a href="http://www.seobythesea.com/services-from-seo-by-the-sea/">SEO services</a></span>, for your site or business <a href="http://www.seobythesea.com/contact-us/">contact</a> Bill Slawski at: <br /><br /> Tel: 1 (442) 244-0941<br /> M-F, 9am - 5pm (pst)<br /><br /> I am the Director of SEO Research at Go Fish Digital. Contact us at <a href="https://gofishdigital.com/">Go Fish Digital</a>: <a href="https://gofishdigital.com/"><img src="http://www.seobythesea.com/wp-content/Gofishdigital-logo.jpg" width="191" height="120" alt="Go Fish Digital" /></a><br /><br /> (703) 596-1353 (9:00am-5:00pm est.) <br /><br /> <div class="g-page" data-width="280" data-href="//plus.google.com/108421660453447189832" data-rel="publisher"></div></div></aside><aside id="meta-11" class="widget inner-padding widget_meta"><h2 class="widget-title">Meta</h2><ul><li><a rel="nofollow" href="http://www.seobythesea.com/wp-login.php">Log in</a></li><li><a href="http://www.seobythesea.com/feed/">Entries feed</a></li><li><a href="http://www.seobythesea.com/comments/feed/">Comments feed</a></li><li><a href="https://wordpress.org/">WordPress.org</a></li></ul></aside><aside id="linkcat-45" class="widget inner-padding widget_links"><h2 class="widget-title"> Find Me At:</h2><ul class='xoxo blogroll'><li><a href="https://about.me/billslawski">About Me &#8211; Bill Slawski</a></li><li><a href="https://www.crunchbase.com/person/bill-slawski#/entity">Bill Slawski &#8211; Crunchbase</a></li><li><a href="https://www.pubcon.com/bios/bill_slawski.htm">Bill Slawski &#8211; Pubcon</a></li><li><a href="https://www.slideshare.net/billslawski" rel="me">Bill Slawski &#8211; Slideshare</a></li><li><a href="https://medium.com/@bill_slawski">Bill Slawski on Medium</a></li><li><a href="https://gofishdigital.com/author/bill/">Bill Slawski&#039;s Go Fish Digital Posts</a></li><li><a href="https://moz.com/community/users/2357">Bill Slawski&#039;s Moz Profile</a></li><li><a href="https://www.pinterest.com/billslawski/" rel="me">Bill Slawski&#039;s Pinterest</a></li><li><a href="http://carlsbadcal.com">carlsbadcal</a></li><li><a href="https://www.facebook.com/bill.slawski">facebook &#8211; bill slawski</a></li><li><a href="https://www.facebook.com/pages/SEO-by-the-Sea/121115417920156" rel="me">facebook &#8211; seo by the sea</a></li><li><a href="https://www.flickr.com/photos/bragadocchio/" rel="me">flickr &#8211; bill slawski</a></li><li><a href="https://www.instagram.com/billslawski/" rel="me">instagram &#8211; Bill Slawski</a></li><li><a href="https://moz.com/blog">moz &#8211; bill slawski</a></li><li><a href="https://www.quora.com/profile/Bill-Slawski">Quora &#8211; Bill Slawski</a></li><li><a href="https://www.searchenginewatch.com/author/bill-slawski/">Search Engine Watch &#8211; Bill Slawski</a></li><li><a href="https://searchnewscentral.com/blog/author/billslawski/">Search News Central Bill Slawski Profile</a></li><li><a href="https://searchengineland.com/author/bill-slawski">searchengineland &#8211; bill slawski</a></li><li><a href="https://www.semrush.com/user/147221905/">SEMRush Profile Bill Slawski</a></li><li><a href="https://www.pinterest.com/billslawski/" rel="me">SEO by the Sea Pinterest Board</a></li><li><a href="https://twitter.com/bill_slawski" rel="me">twitter &#8211; Bill Slawski</a></li><li><a href="https://www.youtube.com/user/bragadocchio" rel="me">Youtube &#8211; bill slawski</a></li></ul></aside><aside id="linkcat-39" class="widget inner-padding widget_links"><h2 class="widget-title">Audio / Video</h2><ul class='xoxo blogroll'><li><a href="http://videolectures.net/">videolectures.net</a></li><li><a href="https://www.youtube.com/user/Google">youtube google channel</a></li><li><a href="https://www.youtube.com/user/googletechtalks?ob=4">youtube google tech talks</a></li></ul></aside><aside id="linkcat-32" class="widget inner-padding widget_links"><h2 class="widget-title">Blogroll</h2><ul class='xoxo blogroll'><li><a href="https://www.allthingsweb.co.uk/blog/">all things web</a></li><li><a href="https://blog.arhg.net/" rel="friend">andrew girdwood</a></li><li><a href="https://codingplayground.blogspot.com/">antonio gulli&#039;s coding playground</a></li><li><a href="https://www.billhartzer.com/">bill hartzer</a></li><li><a href="http://www.blindfiveyearold.com/">blind five year old</a></li><li><a href="https://brodieclark.com/blog/">brodie clark</a></li><li><a href="https://www.buzzmaven.com/">buzzmaven &#8211; scott clark</a></li><li><a href="https://clickfire.com/">clickfire</a></li><li><a href="http://www.daviddalka.com/createvalue/">david dalka</a></li><li><a href="http://www.delawarebusinessblog.com/" rel="friend">delaware business blog</a></li><li><a href="https://equestics.com/blog/">equestics</a></li><li><a href="https://ai.googleblog.com/">Google AI Blog</a></li><li><a href="https://www.ranksense.com/">hamlet batista</a></li><li><a href="https://www.hobo-web.co.uk/">hobo seo</a></li><li><a href="https://ipullrank.com/">ipullrank</a></li><li><a href="https://www.mattcutts.com/blog/">matt cutts: gadgets, google, and seo</a></li><li><a href="https://www.notprovided.eu/" rel="friend colleague">notprovided.eu</a></li><li><a href="https://blog.ouseful.info/">ouseful.Info, the blog</a></li><li><a href="http://www.reubenyau.com/">reuben yau</a></li><li><a href="https://rob.bertholf.com/">rob bertholf</a></li><li><a href="http://www.searchengineguide.com/">search engine guide</a></li><li><a href="https://searchengineland.com/">search engine land</a></li><li><a href="http://www.seodesignsolutions.com/blog/">seo design solutions</a></li><li><a href="http://www.seoskeptic.com/" rel="friend met colleague">seo skeptic</a></li><li><a href="https://www.seo-theory.com/">seo theory</a></li><li><a href="https://vanseodesign.com/blog/">thevanblog</a></li><li><a href="https://blumenthals.com/blog/" rel="friend">understanding google my business and local search</a></li><li><a href="http://www.yackyack.co.uk/">yack yack</a></li></ul></aside><aside id="linkcat-46" class="widget inner-padding widget_links"><h2 class="widget-title">Design and Usability</h2><ul class='xoxo blogroll'><li><a href="https://www.uie.com/">User Interface Engineering</a></li><li><a href="https://www.uxmatters.com/">ux matters</a></li></ul></aside></div></div></div></div><div class="site-footer"><div id="footer-widgets" class="site footer-widgets"><div class="footer-widgets-container grid-container grid-parent"><div class="inside-footer-widgets"><div class="footer-widget-1 grid-parent grid-33 tablet-grid-50 mobile-grid-100"><aside id="categories-371234605" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><ul><li class="cat-item cat-item-18"><a href="http://www.seobythesea.com/category/acquisitions/" title="Acquisitions, mergers, and strategic investments have the potential to transform the technologies that power the Web.  Companies like Google or Yahoo have made acquisitions of other companies for their technology, or to hire their employees because they have experience that might otherwise be difficult to acquire.  When writing about acquisitions, I have tried to include links to granted patents and patent applications that may have come with the acquisition as well.  Most news about acquisitions made on the web for technology companies doesn&#039;t include information about the finances involved in those acquisitions.">Acquisitions</a></li><li class="cat-item cat-item-343"><a href="http://www.seobythesea.com/category/analytics/" title="Analytics involves measuring activity on your site, which can help you understand what people do when they visit your pages.
The search engines have developed tools that site owners can use to learn about visitor activity on their sites.
Making sure analytics is set up correctly on your pages can be helpful, and knowing what the search engines make available is wise.">Analytics</a></li><li class="cat-item cat-item-179"><a href="http://www.seobythesea.com/category/blogging/" title="Posts, ideas, suggestions and questions on blogging, and using a blog. A Blog is short for Web log, which is a log of posts from a person, using focusing on a specific topic.  Many commercial sites have blogs, which they can use to provide news and information to potential customers and provide information that might be found on a search by a search engine.  Many blogs are hobby sites for people who are interested in a specific topic and may be an outlet for their owners to use to share information about the subject of their blog.">Blogging</a></li><li class="cat-item cat-item-29"><a href="http://www.seobythesea.com/category/change/">Change</a></li><li class="cat-item cat-item-6"><a href="http://www.seobythesea.com/category/culture/" title="This is my place to write about culture in the SEO or Search Industries or in life.
It&#039;s not a Topic I add to very often but is one that I will occasionally write to.">Culture</a></li><li class="cat-item cat-item-11"><a href="http://www.seobythesea.com/category/design/" title="Posts on Web design and development covered at SEO by the Sea">Design and Development</a></li><li class="cat-item cat-item-27"><a href="http://www.seobythesea.com/category/environmental/" title="I sometimes write about the environmental influences in the world around me.  It&#039;s one of those things that call to me, and makes me pay attention to the world.">Environmental</a></li><li class="cat-item cat-item-4"><a href="http://www.seobythesea.com/category/events/" title="Information about events, conferences, and gatherings involving search, seo. technology and the Web.
This is where I will write about conferences and events that I attend, and include photos to show what takes place at such events, and where they take place.">Events</a></li><li class="cat-item cat-item-24"><a href="http://www.seobythesea.com/category/fact-extraction/" title="Techniques and approaches that search engines might use to do fact extraction and information from the Web, as uncovered in search-related patents and whitepapers.  These approaches may include natural language processing and knowledge bases, as well as how a search engine may do things such as question-answering.  Patents and papers involving concepts, entities, and knowledge Graphs will be covered by posts in this category.">Fact Extraction and Knowledge Graphs</a></li><li class="cat-item cat-item-12"><a href="http://www.seobythesea.com/category/gadgets/">Gadgets</a></li><li class="cat-item cat-item-392"><a href="http://www.seobythesea.com/category/google-glass/">Google Glass</a></li><li class="cat-item cat-item-266"><a href="http://www.seobythesea.com/category/seo-for-government/" title="Research, thoughts, and observations on search engine optimization and content development for government web sites">Government SEO</a></li><li class="cat-item cat-item-459"><a href="http://www.seobythesea.com/category/image-ranking/">Image Ranking</a></li><li class="cat-item cat-item-14"><a href="http://www.seobythesea.com/category/internet-law/" title="Local, regional, national, and international laws and regulations can impact the way that the Web works, and how businesses and organizations and individuals can use the Web.  Posts under this category explore Internet law and changes to laws involving the internet.">Internet Law</a></li><li class="cat-item cat-item-25"><a href="http://www.seobythesea.com/category/interviews/">Interviews</a></li><li class="cat-item cat-item-391"><a href="http://www.seobythesea.com/category/keyword-research/" title="This section is about keyword research and choosing specific words to optimize a page for, based upon the words that members of the targeted audience of a page might choose to use to search with, and expect to see on the pages of a site they find in search results.">Keyword Research</a></li><li class="cat-item cat-item-447"><a href="http://www.seobythesea.com/category/learning-seo/" title="There aren&#039;t many classes to attend to learn about SEO with.  So, this category focuses upon how someone can find Information and resources to learn SEO with.">Learning SEO</a></li><li class="cat-item cat-item-17"><a href="http://www.seobythesea.com/category/local-search/" title="Like organic search, one of the areas of search that brings a lot of traffic to businesses is Local SEO and Maps.  There have been a number of patents that focus upon local search, and show that it is often about structured data and Semantic marketing.
This is an area where citations have as much value as links, and businesses are considered local entities.  When you optimize a site for a business, often optimizing it for organic search and for local seo providing two separate sets of signals that business can be found through.  One of the earliest patents involving local search at Google was about collecting structured data about local business entities from sources such as data aggregators, enterprise business sites, and local business directories, which has them focusing upon consistency between those data sources, which is a major concern for local SEO.">Local SEO and Maps</a></li><li class="cat-item cat-item-23"><a href="http://www.seobythesea.com/category/media-search/">Media SEO</a></li><li class="cat-item cat-item-9"><a href="http://www.seobythesea.com/category/metablogging/" title="Information about the SEO by the Sea Blog, blogging, and so on.">Metablogging</a></li><li class="cat-item cat-item-15"><a href="http://www.seobythesea.com/category/mobile-search/" title="The amount of people accessing the Web on mobile phones and devices has been outpacing desktop computer users.
Google has been trying to convince site owners to make their sites mobile-friendly, and there have been some patents and papers focusing upon mobile devices accessing the Web.">Mobile and Mobile Search Marketing</a></li><li class="cat-item cat-item-393"><a href="http://www.seobythesea.com/category/mythbusting-seo/" title="There&#039;s a lot of misinformation on the Web about SEO, and this section of my blog is a place to discuss and unravel it.">Mythbusting SEO</a></li><li class="cat-item cat-item-413"><a href="http://www.seobythesea.com/category/open-data/">Open Data</a></li><li class="cat-item cat-item-408"><a href="http://www.seobythesea.com/category/paid-search/">Paid Search</a></li><li class="cat-item cat-item-394"><a href="http://www.seobythesea.com/category/patent-free-friday/">Patent Free Friday</a></li><li class="cat-item cat-item-448"><a href="http://www.seobythesea.com/category/relevance/">Relevance</a></li><li class="cat-item cat-item-13"><a href="http://www.seobythesea.com/category/sea/" title="Posts about white papers, patent filings, information, and strategies and tactics involving Search Engine Advertising">Search Engine Marketing (SEM)</a></li><li class="cat-item cat-item-5"><a href="http://www.seobythesea.com/category/seo/" title="Search Engine Optimization tips and strategies and information, from SEO by the Sea, to help make your website easier to find, and rank in search results.  Search Engine Optimization is marketing within the framework of the Web.  Having an understanding of how Search Engines might crawl and index pages on the web, and rank content from those pages can help a site rank better in Search Results.  Many of the posts in this category focus upon search engine optimization, and different processes that search engines might use to improve the quality of search results for organic search and other types of search verticals.  ">Search Engine Optimization (SEO)</a></li><li class="cat-item cat-item-20"><a href="http://www.seobythesea.com/category/web-spam/" title="Search Engines face many people who try to manipulate search results and have their pages rank higher than their competitors.  These people may engage in Search Engine Spam to do that.  The search engines have filed patents and have written papers that describe how they may fight against the manipulation of search results.">Search Engine Spam</a></li><li class="cat-item cat-item-10"><a href="http://www.seobythesea.com/category/search-engines-and-directories/" title="News and information about search engines and directories on the Web, including patent filings and white papers">Search Engines and Directories</a></li><li class="cat-item cat-item-19"><a href="http://www.seobythesea.com/category/search-people-moving/">Search People Moving</a></li><li class="cat-item cat-item-22"><a href="http://www.seobythesea.com/category/personalization/" title="Will search personalization transform search engines from keyword-driven finders of information to sources of recommendations that attempt to understand and match the intent behind searches?">Search Personalization</a></li><li class="cat-item cat-item-21"><a href="http://www.seobythesea.com/category/searchers-queries/" title="Some patents and some white papers focus upon search queries, and how a search engine might respond to what a searcher might be looking for, and help to fulfill the informational and situational needs they might have.  It is often tempting to think of search queries in terms of the intent behind them, whether they are informational, transactional or navigational.  I recommend that people read the paper A Taxonomy of Web Search by Andrei Broder (who is now at Google) to learn more about the intents behind Search Queries.  With the Web becoming more Semantic and being more about finding entities, it&#039;s possible that looking at search queries to see if they trigger the appearance of an answer box or a featured snippet will become more common.">Search Queries</a></li><li class="cat-item cat-item-395"><a href="http://www.seobythesea.com/category/semantic-search/" title="The inventor of the Web, Tim Berners-Lee came out with a revision of his original vision of the Web when he started writing about the Semantic Web.  He published an article in Scientific American about The Semantic Web, which is recommended reading.  Search on the Web has been evolving to focus more on showing results that find things, instead of strings, or matching keywords within queries to keywords on documents on the web. We are in a age of semantic search.  This is seen in Google&#039;s original fact repository, followed by their knowledge graph, and Microsoft&#039;s concept graph.  Google, Bing, Yahoo, and Yandex all are followers of schema.org structured data markup, and it can be used to show rich results in search results.  We see semantic search results in featured snippets, rich results, structured results, knowledge panels, and special query processing of entities during this semantic search.">Semantic Search</a></li><li class="cat-item cat-item-31"><a href="http://www.seobythesea.com/category/small-business/">Small Business</a></li><li class="cat-item cat-item-16"><a href="http://www.seobythesea.com/category/social-search/">Social Media and Social Search</a></li><li class="cat-item cat-item-7"><a href="http://www.seobythesea.com/category/usability/">Usability</a></li><li class="cat-item cat-item-460"><a href="http://www.seobythesea.com/category/voice-search/">voice search</a></li></ul></aside><aside id="archives-8" class="widget inner-padding widget_archive"><h2 class="widget-title">Archives</h2><ul><li><a href='http://www.seobythesea.com/2020/04/'>April 2020</a></li><li><a href='http://www.seobythesea.com/2020/03/'>March 2020</a></li><li><a href='http://www.seobythesea.com/2020/01/'>January 2020</a></li><li><a href='http://www.seobythesea.com/2019/12/'>December 2019</a></li><li><a href='http://www.seobythesea.com/2019/11/'>November 2019</a></li><li><a href='http://www.seobythesea.com/2019/10/'>October 2019</a></li><li><a href='http://www.seobythesea.com/2019/09/'>September 2019</a></li><li><a href='http://www.seobythesea.com/2019/08/'>August 2019</a></li><li><a href='http://www.seobythesea.com/2019/07/'>July 2019</a></li><li><a href='http://www.seobythesea.com/2019/06/'>June 2019</a></li><li><a href='http://www.seobythesea.com/2019/05/'>May 2019</a></li><li><a href='http://www.seobythesea.com/2019/02/'>February 2019</a></li><li><a href='http://www.seobythesea.com/2019/01/'>January 2019</a></li><li><a href='http://www.seobythesea.com/2018/10/'>October 2018</a></li><li><a href='http://www.seobythesea.com/2018/07/'>July 2018</a></li><li><a href='http://www.seobythesea.com/2018/06/'>June 2018</a></li><li><a href='http://www.seobythesea.com/2018/04/'>April 2018</a></li><li><a href='http://www.seobythesea.com/2018/03/'>March 2018</a></li><li><a href='http://www.seobythesea.com/2018/02/'>February 2018</a></li><li><a href='http://www.seobythesea.com/2018/01/'>January 2018</a></li><li><a href='http://www.seobythesea.com/2017/12/'>December 2017</a></li><li><a href='http://www.seobythesea.com/2017/11/'>November 2017</a></li><li><a href='http://www.seobythesea.com/2017/10/'>October 2017</a></li><li><a href='http://www.seobythesea.com/2017/09/'>September 2017</a></li><li><a href='http://www.seobythesea.com/2017/08/'>August 2017</a></li><li><a href='http://www.seobythesea.com/2017/06/'>June 2017</a></li><li><a href='http://www.seobythesea.com/2017/05/'>May 2017</a></li><li><a href='http://www.seobythesea.com/2017/04/'>April 2017</a></li><li><a href='http://www.seobythesea.com/2017/03/'>March 2017</a></li><li><a href='http://www.seobythesea.com/2017/02/'>February 2017</a></li><li><a href='http://www.seobythesea.com/2017/01/'>January 2017</a></li><li><a href='http://www.seobythesea.com/2016/12/'>December 2016</a></li><li><a href='http://www.seobythesea.com/2016/11/'>November 2016</a></li><li><a href='http://www.seobythesea.com/2016/10/'>October 2016</a></li><li><a href='http://www.seobythesea.com/2016/09/'>September 2016</a></li><li><a href='http://www.seobythesea.com/2016/08/'>August 2016</a></li><li><a href='http://www.seobythesea.com/2016/07/'>July 2016</a></li><li><a href='http://www.seobythesea.com/2016/06/'>June 2016</a></li><li><a href='http://www.seobythesea.com/2016/05/'>May 2016</a></li><li><a href='http://www.seobythesea.com/2016/04/'>April 2016</a></li><li><a href='http://www.seobythesea.com/2016/03/'>March 2016</a></li><li><a href='http://www.seobythesea.com/2016/01/'>January 2016</a></li><li><a href='http://www.seobythesea.com/2015/12/'>December 2015</a></li><li><a href='http://www.seobythesea.com/2015/11/'>November 2015</a></li><li><a href='http://www.seobythesea.com/2015/10/'>October 2015</a></li><li><a href='http://www.seobythesea.com/2015/09/'>September 2015</a></li><li><a href='http://www.seobythesea.com/2015/08/'>August 2015</a></li><li><a href='http://www.seobythesea.com/2015/07/'>July 2015</a></li><li><a href='http://www.seobythesea.com/2015/06/'>June 2015</a></li><li><a href='http://www.seobythesea.com/2015/05/'>May 2015</a></li><li><a href='http://www.seobythesea.com/2015/04/'>April 2015</a></li><li><a href='http://www.seobythesea.com/2015/03/'>March 2015</a></li><li><a href='http://www.seobythesea.com/2015/02/'>February 2015</a></li><li><a href='http://www.seobythesea.com/2015/01/'>January 2015</a></li><li><a href='http://www.seobythesea.com/2014/12/'>December 2014</a></li><li><a href='http://www.seobythesea.com/2014/11/'>November 2014</a></li><li><a href='http://www.seobythesea.com/2014/10/'>October 2014</a></li><li><a href='http://www.seobythesea.com/2014/09/'>September 2014</a></li><li><a href='http://www.seobythesea.com/2014/08/'>August 2014</a></li><li><a href='http://www.seobythesea.com/2014/07/'>July 2014</a></li><li><a href='http://www.seobythesea.com/2014/06/'>June 2014</a></li><li><a href='http://www.seobythesea.com/2014/05/'>May 2014</a></li><li><a href='http://www.seobythesea.com/2014/04/'>April 2014</a></li><li><a href='http://www.seobythesea.com/2014/03/'>March 2014</a></li><li><a href='http://www.seobythesea.com/2014/02/'>February 2014</a></li><li><a href='http://www.seobythesea.com/2014/01/'>January 2014</a></li><li><a href='http://www.seobythesea.com/2013/12/'>December 2013</a></li><li><a href='http://www.seobythesea.com/2013/11/'>November 2013</a></li><li><a href='http://www.seobythesea.com/2013/10/'>October 2013</a></li><li><a href='http://www.seobythesea.com/2013/09/'>September 2013</a></li><li><a href='http://www.seobythesea.com/2013/08/'>August 2013</a></li><li><a href='http://www.seobythesea.com/2013/07/'>July 2013</a></li><li><a href='http://www.seobythesea.com/2013/06/'>June 2013</a></li><li><a href='http://www.seobythesea.com/2013/05/'>May 2013</a></li><li><a href='http://www.seobythesea.com/2013/04/'>April 2013</a></li><li><a href='http://www.seobythesea.com/2013/03/'>March 2013</a></li><li><a href='http://www.seobythesea.com/2013/02/'>February 2013</a></li><li><a href='http://www.seobythesea.com/2013/01/'>January 2013</a></li><li><a href='http://www.seobythesea.com/2012/12/'>December 2012</a></li><li><a href='http://www.seobythesea.com/2012/11/'>November 2012</a></li><li><a href='http://www.seobythesea.com/2012/10/'>October 2012</a></li><li><a href='http://www.seobythesea.com/2012/09/'>September 2012</a></li><li><a href='http://www.seobythesea.com/2012/08/'>August 2012</a></li><li><a href='http://www.seobythesea.com/2012/07/'>July 2012</a></li><li><a href='http://www.seobythesea.com/2012/06/'>June 2012</a></li><li><a href='http://www.seobythesea.com/2012/05/'>May 2012</a></li><li><a href='http://www.seobythesea.com/2012/04/'>April 2012</a></li><li><a href='http://www.seobythesea.com/2012/03/'>March 2012</a></li><li><a href='http://www.seobythesea.com/2012/02/'>February 2012</a></li><li><a href='http://www.seobythesea.com/2012/01/'>January 2012</a></li><li><a href='http://www.seobythesea.com/2011/12/'>December 2011</a></li><li><a href='http://www.seobythesea.com/2011/11/'>November 2011</a></li><li><a href='http://www.seobythesea.com/2011/10/'>October 2011</a></li><li><a href='http://www.seobythesea.com/2011/09/'>September 2011</a></li><li><a href='http://www.seobythesea.com/2011/08/'>August 2011</a></li><li><a href='http://www.seobythesea.com/2011/07/'>July 2011</a></li><li><a href='http://www.seobythesea.com/2011/06/'>June 2011</a></li><li><a href='http://www.seobythesea.com/2011/05/'>May 2011</a></li><li><a href='http://www.seobythesea.com/2011/04/'>April 2011</a></li><li><a href='http://www.seobythesea.com/2011/03/'>March 2011</a></li><li><a href='http://www.seobythesea.com/2011/02/'>February 2011</a></li><li><a href='http://www.seobythesea.com/2011/01/'>January 2011</a></li><li><a href='http://www.seobythesea.com/2010/12/'>December 2010</a></li><li><a href='http://www.seobythesea.com/2010/11/'>November 2010</a></li><li><a href='http://www.seobythesea.com/2010/10/'>October 2010</a></li><li><a href='http://www.seobythesea.com/2010/09/'>September 2010</a></li><li><a href='http://www.seobythesea.com/2010/08/'>August 2010</a></li><li><a href='http://www.seobythesea.com/2010/07/'>July 2010</a></li><li><a href='http://www.seobythesea.com/2010/06/'>June 2010</a></li><li><a href='http://www.seobythesea.com/2010/05/'>May 2010</a></li><li><a href='http://www.seobythesea.com/2010/04/'>April 2010</a></li><li><a href='http://www.seobythesea.com/2010/03/'>March 2010</a></li><li><a href='http://www.seobythesea.com/2010/02/'>February 2010</a></li><li><a href='http://www.seobythesea.com/2010/01/'>January 2010</a></li><li><a href='http://www.seobythesea.com/2009/12/'>December 2009</a></li><li><a href='http://www.seobythesea.com/2009/11/'>November 2009</a></li><li><a href='http://www.seobythesea.com/2009/10/'>October 2009</a></li><li><a href='http://www.seobythesea.com/2009/09/'>September 2009</a></li><li><a href='http://www.seobythesea.com/2009/08/'>August 2009</a></li><li><a href='http://www.seobythesea.com/2009/07/'>July 2009</a></li><li><a href='http://www.seobythesea.com/2009/06/'>June 2009</a></li><li><a href='http://www.seobythesea.com/2009/05/'>May 2009</a></li><li><a href='http://www.seobythesea.com/2009/04/'>April 2009</a></li><li><a href='http://www.seobythesea.com/2009/03/'>March 2009</a></li><li><a href='http://www.seobythesea.com/2009/02/'>February 2009</a></li><li><a href='http://www.seobythesea.com/2009/01/'>January 2009</a></li><li><a href='http://www.seobythesea.com/2008/12/'>December 2008</a></li><li><a href='http://www.seobythesea.com/2008/11/'>November 2008</a></li><li><a href='http://www.seobythesea.com/2008/10/'>October 2008</a></li><li><a href='http://www.seobythesea.com/2008/09/'>September 2008</a></li><li><a href='http://www.seobythesea.com/2008/08/'>August 2008</a></li><li><a href='http://www.seobythesea.com/2008/07/'>July 2008</a></li><li><a href='http://www.seobythesea.com/2008/06/'>June 2008</a></li><li><a href='http://www.seobythesea.com/2008/05/'>May 2008</a></li><li><a href='http://www.seobythesea.com/2008/04/'>April 2008</a></li><li><a href='http://www.seobythesea.com/2008/03/'>March 2008</a></li><li><a href='http://www.seobythesea.com/2008/02/'>February 2008</a></li><li><a href='http://www.seobythesea.com/2008/01/'>January 2008</a></li><li><a href='http://www.seobythesea.com/2007/12/'>December 2007</a></li><li><a href='http://www.seobythesea.com/2007/11/'>November 2007</a></li><li><a href='http://www.seobythesea.com/2007/10/'>October 2007</a></li><li><a href='http://www.seobythesea.com/2007/09/'>September 2007</a></li><li><a href='http://www.seobythesea.com/2007/08/'>August 2007</a></li><li><a href='http://www.seobythesea.com/2007/07/'>July 2007</a></li><li><a href='http://www.seobythesea.com/2007/06/'>June 2007</a></li><li><a href='http://www.seobythesea.com/2007/05/'>May 2007</a></li><li><a href='http://www.seobythesea.com/2007/04/'>April 2007</a></li><li><a href='http://www.seobythesea.com/2007/03/'>March 2007</a></li><li><a href='http://www.seobythesea.com/2007/02/'>February 2007</a></li><li><a href='http://www.seobythesea.com/2007/01/'>January 2007</a></li><li><a href='http://www.seobythesea.com/2006/12/'>December 2006</a></li><li><a href='http://www.seobythesea.com/2006/11/'>November 2006</a></li><li><a href='http://www.seobythesea.com/2006/10/'>October 2006</a></li><li><a href='http://www.seobythesea.com/2006/09/'>September 2006</a></li><li><a href='http://www.seobythesea.com/2006/08/'>August 2006</a></li><li><a href='http://www.seobythesea.com/2006/07/'>July 2006</a></li><li><a href='http://www.seobythesea.com/2006/06/'>June 2006</a></li><li><a href='http://www.seobythesea.com/2006/05/'>May 2006</a></li><li><a href='http://www.seobythesea.com/2006/04/'>April 2006</a></li><li><a href='http://www.seobythesea.com/2006/03/'>March 2006</a></li><li><a href='http://www.seobythesea.com/2006/02/'>February 2006</a></li><li><a href='http://www.seobythesea.com/2006/01/'>January 2006</a></li><li><a href='http://www.seobythesea.com/2005/12/'>December 2005</a></li><li><a href='http://www.seobythesea.com/2005/11/'>November 2005</a></li><li><a href='http://www.seobythesea.com/2005/10/'>October 2005</a></li><li><a href='http://www.seobythesea.com/2005/09/'>September 2005</a></li><li><a href='http://www.seobythesea.com/2005/06/'>June 2005</a></li></ul></aside></div><div class="footer-widget-2 grid-parent grid-33 tablet-grid-50 mobile-grid-100"></div><div class="footer-widget-3 grid-parent grid-33 tablet-grid-50 mobile-grid-100"></div></div></div></div><footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope><div class="inside-site-info grid-container grid-parent"><div class="copyright-bar"> <span class="copyright">&copy; 2020 SEO by the Sea &#9875;</span> &bull; Powered by <a href="https://generatepress.com" itemprop="url">GeneratePress</a></div></div></footer></div> <script defer type='text/javascript' src='http://www.seobythesea.com/wp-content/siteground-optimizer-assets/anti-spam-script.min.js'></script> <script defer type='text/javascript'>var dpsp_pin_button_data = {"pin_description_source":"image_alt_tag","pinterest_pinnable_images":"all_images","pinterest_button_share_behavior":"post_image","button_position":"top_left","button_shape":"rectangular","minimum_image_width":"200","minimum_image_height":"200","show_button_text_label":"yes","button_text_label":"Save","button_share_behavior":"hover_image"}</script> <script defer type='text/javascript' src='http://www.seobythesea.com/wp-content/siteground-optimizer-assets/dpsp-frontend-js-pro.min.js'></script> <!--[if lte IE 11]> <script defer type='text/javascript' src='http://www.seobythesea.com/wp-content/themes/generatepress/js/classList.min.js'></script> <![endif]--> <script defer type='text/javascript' src='http://www.seobythesea.com/wp-content/themes/generatepress/js/menu.min.js'></script> <script defer type='text/javascript' src='http://www.seobythesea.com/wp-content/themes/generatepress/js/a11y.min.js'></script> <script type='text/javascript' src='http://www.seobythesea.com/wp-includes/js/wp-embed.min.js'></script> <script async="async" type='text/javascript' src='http://www.seobythesea.com/wp-content/siteground-optimizer-assets/akismet-form.min.js'></script> </body></html>